Closed Bug 835127 Opened 8 years ago Closed 8 years ago

Vorbis 5.1 doesn't play (no sound)

Categories

(Core :: Audio/Video, defect)

18 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 521615

People

(Reporter: aufkrawall, Unassigned)

Details

Attachments

(2 files)

1.22 MB, application/octet-stream
Details
929.11 KB, video/ogg
Details
Attached file samples.7z
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

I dragged and dropped a Vorbis 5.1 file into Firefox' window.




Actual results:

Then the play slider moves and but there is no sound output.


Expected results:

Firefox should be able to play 5.1 Vorbis just like Chrome can do it.
Vorbis stereo files play fine.
I've attached Vorbis 5.1 and stereo files to reproduce.
FWIW, Opera 12.13 has Sound, too.
Component: Untriaged → Video/Audio
Product: Firefox → Core
General
Complete name                            : 5.1.ogg
Format                                   : OGG
File size                                : 929 KiB
Duration                                 : 10s 52ms
Overall bit rate mode                    : Variable
Overall bit rate                         : 757 Kbps

Audio
ID                                       : 10822 (0x2A46)
Format                                   : Vorbis
Format settings, Floor                   : 1 / 8710
Duration                                 : 10s 52ms
Bit rate mode                            : Variable
Bit rate                                 : 840 Kbps
Channel(s)                               : 6 channels
Sampling rate                            : 48.0 KHz
Compression mode                         : Lossy
Stream size                              : 1.01 MiB
Writing library                          : Lancer 20110424 (UTC 2011-04-24)
Attached video 5.1.ogg
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 521615
You need to log in before you can comment on or make changes to this bug.