Closed Bug 521615 Opened 12 years ago Closed 5 years ago

Support surround sound (e.g. 5.1) media playback

Categories

(Core :: Audio/Video: Playback, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: keul, Unassigned)

References

(Depends on 1 open bug, )

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.1.4) Gecko/20091007 Firefox/3.5.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; fr; rv:1.9.1.4) Gecko/20091007 Firefox/3.5.4

With firefox 3.7a1pre, there's also no sound in some others videos
All videos are working with VLC and google Chrome

Reproducible: Always

Steps to Reproduce:
1. visit http://kyon.haruhi.fr/videos/test.php and play video (with firefox 3.5, 3.7 and Chrome)
Actual Results:  
No sound

Expected Results:  
Sound
Component: General → Video/Audio
Product: Firefox → Core
QA Contact: general → video.audio
Component: Video/Audio → General
Product: Core → Firefox
Hardware: x86_64 → x86
Version: unspecified → 3.5 Branch
Are you saying it used to work in 3.5 and it's broken in recent builds?  Or just that it doesn't work in Firefox at all?  I think it's the latter that's true.

The basic problem is that we open the waveAPI backend using WAVEFORMATEX, which only supports two channel PCM.  We need to move to using WAVEFORMATEXTENSIBLE, which I plan to do in the near future as part of some other changes.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Component: General → Video/Audio
Product: Firefox → Core
Version: 3.5 Branch → Trunk
In fact, there's two bugs : the first video never get sound because it's 5.1 ch.

For the two second videos, there's sound, but it's broken in recent builds.

Maybe I should have reported two distinct bugs?
(In reply to comment #2)
> For the two second videos, there's sound, but it's broken in recent builds.

That's probably bug 520493.
Verified that the non-playing audio in the latter two examples is caused by some variant of bug 520493.  I'll make this bug an enhancement bug about adding 5.1 support.
Severity: major → enhancement
Summary: No sound with 5.1 vorbis/theora in <video> → Support surround sound (e.g. 5.1) Vorbis (in Ogg/WebM)
Duplicate of this bug: 603157
Duplicate of this bug: 552324
Assignee: nobody → kinetik
Status: NEW → ASSIGNED
Depends on: cubeb
Duplicate of this bug: 720057
Depends on: 782507
Depends on: 790459
Duplicate of this bug: 835127
Assignee: kinetik → nobody
first and second vid is okay with sound(in 5.1), but third one is no-audio in FF27 branch
All vids work fine here (36.0a1 on Linux).
Gummi, this bug only Windows
Assignee: nobody → kinetik
Summary: Support surround sound (e.g. 5.1) Vorbis (in Ogg/WebM) → Support surround sound (e.g. 5.1) media playback
OS: Windows Vista → All
Hardware: x86 → All
Component: Audio/Video → Audio/Video: Playback
Assignee: kinetik → nobody
Status: ASSIGNED → NEW
You'll find that all those videos plays just fine with the new WAV decoder.

While they all play in stereo, channel positioning is good in Nightly (49)
I mark it as WFM. playback of media with surround tracks now works just fine

Cubeb (the audio playback backend) however, only supports stereo, but there's a bug for that.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.