Closed Bug 835241 Opened 7 years ago Closed 7 years ago

Reload button reloads cached copy

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 21

People

(Reporter: gcp, Assigned: mfinkle)

References

Details

Attachments

(1 file)

Potentially related to bug 834743:

1) Go to a site like reddit.com, load a story you browsed recently, say the previous day. (Reproducing this may require Firefox still being in memory)

2) Load the same site on desktop. Notice that there are a load more comments and the comment dates all have longer durations (x hours ago) than on Firefox for Android.

3) Click reload. See exact site as in (1) load.

We seem to be reloading pages on cache even when this is highly undesirable, and even requesting a reload doesn't solve it. (Which makes one wonder what that button is for anyway!)
We have had reports of this before. This bug might even be a dupe, but I use it for now. I am testing a patch to use "force-reload" instead of "cached-reload". I borrowed the code from desktop, which it uses for ctrl-f5.
Attached patch patchSplinter Review
Patch is mainly taken from here:
http://mxr.mozilla.org/mozilla-central/source/browser/base/content/browser.js#2808
Assignee: nobody → mark.finkle
Attachment #707098 - Flags: review?(bnicholson)
Attachment #707098 - Flags: review?(bnicholson) → review+
This (also) happens if device sees a connection, but can't establish a data transfer (e.g. being too far away from the Wifi access point, directly loading the after connecting to Wifi etc.)

Also keep in mind that Gecko won't load a page new if it is already open in a different tab. Comment #0 is unclear if other tabs are open.
>Also keep in mind that Gecko won't load a page new if it is already open in a 
>different tab. Comment #0 is unclear if other tabs are open.

I'm reloading in the open tab.
https://hg.mozilla.org/mozilla-central/rev/595c77e4624c
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Depends on: 838523
You need to log in before you can comment on or make changes to this bug.