Work - [polish] Firefox app bar location text does not revert to the previous value when user presses escape

RESOLVED FIXED in Firefox 23

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: mbrubeck, Assigned: ally)

Tracking

({platform-parity, polish, ux-error-recovery})

unspecified
Firefox 23
x86_64
Windows 8.1
platform-parity, polish, ux-error-recovery

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=work)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

6 years ago
Steps to reproduce:
1. Load a page in Metro Firefox.
2. After the page loads, focus the location bar.
3. Type a word.
4. Press the Escape key.

Expected results: The URL bar reverts to the address of the current page.

Actual results: The URL bar hides, but still contains the typed word.
Summary: [polish] Metro url bar text does not revert to the previous value when user presses escape → Work - [polish] Metro url bar text does not revert to the previous value when user presses escape
Whiteboard: feature=work

Updated

6 years ago
Summary: Work - [polish] Metro url bar text does not revert to the previous value when user presses escape → Work - [polish] Firefox app bar location text does not revert to the previous value when user presses escape
Blocks: 845152
No longer blocks: 831899
(Reporter)

Updated

6 years ago
Assignee: mbrubeck → nobody
(Assignee)

Updated

6 years ago
Assignee: nobody → ally
(Assignee)

Comment 1

6 years ago
- I left the new {} braces in one case of handleEscape() because it is in line with our style guide.
- I left some of the more interesting error console logging for you in case you'd like to see the output during feedback.
- I think lastKnownGoodURL should move into browserUI, and I welcome better names for that variable. :/
Attachment #744902 - Flags: feedback?(mbrubeck)
(Reporter)

Comment 2

6 years ago
Comment on attachment 744902 [details] [diff] [review]
wip - functional, needs some code hygiene

Review of attachment 744902 [details] [diff] [review]:
-----------------------------------------------------------------

Yeah, this looks good to me.

::: browser/metro/base/content/browser-ui.js
@@ +57,5 @@
>    });
>  });
>  
> +let lastKnownGoodURL = ""; //used when the user wants to escape unfinished url entry
> +// TODO I think this belongs in browserUI,not out here with Elements

I agree.
Attachment #744902 - Flags: feedback?(mbrubeck) → feedback+
(Assignee)

Comment 3

6 years ago
Attachment #744902 - Attachment is obsolete: true
Attachment #746051 - Flags: review?(mbrubeck)
(Reporter)

Comment 4

6 years ago
Comment on attachment 746051 [details] [diff] [review]
save urls when they are set

Review of attachment 746051 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/metro/base/content/browser-ui.js
@@ +77,4 @@
>    get _back() { return document.getElementById("cmd_back"); },
>    get _forward() { return document.getElementById("cmd_forward"); },
>  
> +  lastKnownGoodURL : "", //used when the user wants to escape unfinished url entry

Nit: no space before ":"

No rationale except consistency.  Mozilla JS code overall is divided on this issue, but this is the dominant style in Metro so I've added it to https://wiki.mozilla.org/Firefox/Windows_8_Metro_Style_Guides#JS
Attachment #746051 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/mozilla-central/rev/aa00d8de9a79
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.