Reported Web Forgery's "Get me out of here" goes to about:home; allows going Back

RESOLVED DUPLICATE of bug 442839

Status

()

Toolkit
Safe Browsing
RESOLVED DUPLICATE of bug 442839
5 years ago
4 years ago

People

(Reporter: bryce_allen22, Unassigned)

Tracking

19 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130123083802

Steps to reproduce:

Went to a site that was suspicious and when the reported web forgery display appeared(red) I pressed get me out of here and doesnt go back to designated home page also the back button allows to go back to site.



Actual results:

It goes to not my home page which is www.google.com and which i thought it was designed to do instead it goes to the firefox about:home page? also when you press get me out of here and it gets out of the web page but  i would think it would not allow the user to go back to the site by using the back button?


Expected results:

Doesn't allow user to press the back button and go back to malicious site(maybe make the user input the suspicious site into exceptions if they think its safe) and also it goes to home page www.google.com not the firefox generated about:home page

Comment 1

5 years ago
What if one of your home pages is a suspicious one?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Component: Untriaged → Phishing Protection
Resolution: --- → DUPLICATE
Summary: Reported Web Forgery → Reported Web Forgery's "Get me out of here" goes to about:home; allows going Back
Duplicate of bug: 442839

Comment 2

5 years ago
Please file a separate bug about going back.  See also: bug 403055.
(Assignee)

Updated

4 years ago
Component: Phishing Protection → Phishing Protection
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.