Use icons for tab switching in Tabs UI

VERIFIED FIXED in Firefox 20

Status

()

defect
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: sriram, Assigned: sriram)

Tracking

unspecified
Firefox 21
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 verified, firefox21 verified)

Details

Attachments

(3 attachments)

It's better to use icons for tabs -- instead of text or spinner -- for switching different panels in tabs ui.
Assignee

Updated

7 years ago
Blocks: 817675
This patch adds a new IconTabWidget to handle the tab switching.
Attachment #707851 - Flags: review?(mark.finkle)
Assignee

Updated

7 years ago
Attachment #707851 - Attachment description: Patch → Part 1: Icon TabWidget
This adds a dark toolbar. The divider should be underneath the buttons, hence a RelativeLayout is used.

Since the toolbar is dark, the tabs button has to be dark when in opened state.
Also, the same should be reflected in personas.

Late realization: I could have renamed the tabs_tray_selected_bg to tabs_tray_dark_bg. :(
Attachment #707866 - Flags: review?(mark.finkle)
Comment on attachment 707851 [details] [diff] [review]
Part 1: Icon TabWidget


>diff --git a/mobile/android/base/GeckoViewsFactory.java b/mobile/android/base/GeckoViewsFactory.java

Can you remove the Log that always outputs the view anme? Let's just keep the Log that warns for a missing view.
Attachment #707851 - Flags: review?(mark.finkle) → review+
Attachment #707866 - Flags: review?(mark.finkle) → review+
I had wrongly copied the tab-icons to xlarge folder instead of large folder. That's rectified in this patch.
Attachment #708309 - Flags: review?(mark.finkle)
Attachment #708309 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/4271cc336457
https://hg.mozilla.org/mozilla-central/rev/445674b9dd09
https://hg.mozilla.org/mozilla-central/rev/ffe303f6ee85
Assignee: nobody → sriram
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 707851 [details] [diff] [review]
Part 1: Icon TabWidget

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New UI.
User impact if declined: Spinners on phones and tablets to switch tab panels.
Testing completed (on m-c, etc.): Landed in m-c on 01/31
Risk to taking this patch (and alternatives if risky): Low.
String or UUID changes made by this patch: None.
Attachment #707851 - Flags: approval-mozilla-aurora?
Comment on attachment 707866 [details] [diff] [review]
Part 2: Dark toolbar

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New UI.
User impact if declined: Darker toolbar for  tabs-ui will not be seen.
Testing completed (on m-c, etc.): Landed in m-c on 01/31
Risk to taking this patch (and alternatives if risky): Low.
String or UUID changes made by this patch: None.
Attachment #707866 - Flags: approval-mozilla-aurora?
Comment on attachment 708309 [details] [diff] [review]
Part 3: 7" tablet tabs-ui

[Approval Request Comment]
Bug caused by (feature/regressing bug #): New UI.
User impact if declined: 7" will have blurry icons.
Testing completed (on m-c, etc.): Landed in m-c on 01/31
Risk to taking this patch (and alternatives if risky): Very low. Just moving images around.
String or UUID changes made by this patch: None.
Attachment #708309 - Flags: approval-mozilla-aurora?
Attachment #707851 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #707866 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #708309 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
The icon for Sync should have been arrows in a circle, much like the desktop Sync button. The current icon is similar to what they use in Android to indicate connectivity.

Comment 12

6 years ago
Tabs have icons for switching different panels in Tabs UI. Closing bug as verified fixed on: Nightly 21.0a1(2013-02-07) and Aurora 20.0a2(2013-02-07), using Samsung Galaxy Tab 10.1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.