[OPEN_][SMS]The message which we receive can not be opened to view.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: Firefox_Mozilla, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-)

Details

(Whiteboard: [MZ])

Attachments

(2 attachments)

465.62 KB, application/x-7z-compressed
Details
93.64 KB, application/x-7z-compressed
Details
(Reporter)

Description

6 years ago
Created attachment 708027 [details]
logs

Steps to reproduce:
1.we use other phones to send a message to our phone;
2.wait receive this message and view;

Expected results:
1.we receive and view this message successful.

Actual results:
1.we receive this message successful, but the can not view this message. When we tap the message in SMS list or in status bar, it does not have feedback or it is shown null.
For example: We send a message to ourself. The telephone number is 18602565193. When we enter the message “abcde” and send. Then the message is received. It is shown in status bar, but only have message content and not have the telephone number. When we tap the status bar or in SMS list to view this message, it does not have feedback or it is shown null.
(Reporter)

Comment 1

6 years ago
Created attachment 708028 [details]
screenshots

Updated

6 years ago
Status: UNCONFIRMED → NEW
blocking-b2g: --- → tef?
Ever confirmed: true

Updated

6 years ago
Whiteboard: [MZ]

Comment 2

6 years ago
Al - were you able to reproduce? What build did you use? We weren't able to repro in triage with the latest nightly.
Keywords: qawanted
Attachment #708028 - Attachment mime type: text/plain → image/png
Attachment #708028 - Attachment mime type: image/png → application/x-7z-compressed
Attachment #708027 - Attachment mime type: text/plain → application/x-7z-compressed

Comment 3

6 years ago
Please re-nominate if anybody is able to reproduce.
blocking-b2g: tef? → -

Comment 4

6 years ago
Tested on a Unagi Device, Build Id: 20130204070202
Git Commit Info : 2013-02-01 13:43:40 , 04e3e923bdae0773b0133ffa4958831...  (did an update over the air)

I am able to reproduce this issue, but in a different way. 

## Repro : (a) Firstly, I try to send a message from my unagi device (AT & T connection) to my iphone. The message is sent successfully. Then I reply from my iPhone to my unagi device. 
                 (b) Stay on the same messaging window (single user conversation window). 

## Expected : The received replies/messages are populated on the single conversation window with that user(in this case, my iPhone)

##Actual:  When you receive a message, the notification pops up, but you cannot see the incoming message in the message window (assuming that you are still in the same message window - single user conversation window) . You must pull down the notification tray and then tap on the notification or, tap on Back arrow (<) to go back to your List of messages and then tap on the conversation that you wish to continue to see the received messages. This happens only for the first time (i.e. either when you initiate a conversation with your unagi device or the other party (in this case my iPhone) tries to initiate a conversation). The subsequent replies/messages are displayed correctly on the single conversation window as and when they are being sent.

Updated

6 years ago
Flags: needinfo?
Hi all,

I could not reproduce this with the latest build I can get and the build in Comment 4 (Build Id: 20130204070202).

I've tried both STRs in Comment 0 & Comment 4.
Can anyone help provide more info if it's reproducibile, like the number is with internal code (country code) or if roaming is invovled or not? 

Thanks.
Flags: needinfo?

Comment 6

6 years ago
@ Rudy, The number in my Unagi as well as my iPhone is with internal code. No roaming is involved here.
Hi,

I still could not reproduce this issue with international code.
Ping Vicamo,

Could you please help check the logs in Comment 0 to see if this is related to Bug 833291 or provide other insights for this issue?

Thanks.
Flags: needinfo?(vyang)

Comment 9

6 years ago
After checking with Vicamo, it is not related to bug 833291. And I could not reproduce this issue either

Hi Sreenidhi, where did you do this test? It seems related to bug 834755. Can you try the patch of Bug 839094(the duplication of bug 834755)?
Flags: needinfo?(vyang)

Comment 10

6 years ago
Unagi Build:Gecko-854a86c.Gaia-601f50f

I've used another Unagi with the same build and an IPhone 4 to send/received SMS. Both with internal number (no roaming).

Steps done:

1.Send SMS to the Unagi (from the other Unagi or from the iPhone)
2.Wait receive the messages
3.I receive and view the messages successfully.It is shown in the status bar and tapping in the SMS list in the SMS App, and both the message content and the telephone number.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME

Comment 11

6 years ago
Hi Ken, I dont think this has to do anything with country codes and stuff. The messages are received correctly from another phone (when you try to initiate a conversation with Unagi), if you type in the number in recipient box directly and not choosing recipients from the contacts app (the man-like icon on the top right corner)

(In reply to Ken Chang from comment #9)
> After checking with Vicamo, it is not related to bug 833291. And I could not
> reproduce this issue either
> 
> Hi Sreenidhi, where did you do this test? It seems related to bug 834755.
> Can you try the patch of Bug 839094(the duplication of bug 834755)?
You need to log in before you can comment on or make changes to this bug.