Messages not launched when icon tapped

NEW
Unassigned

Status

()

P5
normal
6 years ago
6 months ago

People

(Reporter: cjones, Unassigned)

Tracking

unspecified
x86_64
Linux
Points:
---

Firefox Tracking Flags

(blocking-b2g:-, b2g18+)

Details

Hand-wavy STR
 (1) Have Phone, Settings, Browser, Clock, Maps and maybe Email running in background
 (2) Lock phone, leave idle
 (3) Unlock phone, quickly tap Messages icon to launch it

The symptom I see is that Messages just has a grayed out screen and there's no Messages process.  There's an entry for Messages in the task switcher though.

I wasn't able to tell what happened from logcat/dmesg because of bug 836505 causing the log to be flooded.

Possibly related to bug 834059 and friends.

jlebar, if you know of work that might fix this please let me know / set dep here.
Keywords: qawanted
> jlebar, if you know of work that might fix this please let me know / set dep here.

Offhand, this does not seem related to the LMK work I've been doing.

Unless perhaps the messages app takes forever to start up, gets sent to the background (thanks, Gaia), and then gets killed...
Component: DOM: Apps → DOM: Mozilla Extensions
(In reply to Chris Jones [:cjones] [:warhammer] from comment #0)
> Hand-wavy STR
>  (1) Have Phone, Settings, Browser, Clock, Maps and maybe Email running in
> background
>  (2) Lock phone, leave idle
>  (3) Unlock phone, quickly tap Messages icon to launch it
> 
> The symptom I see is that Messages just has a grayed out screen and there's
> no Messages process.  There's an entry for Messages in the task switcher
> though.
> 
> I wasn't able to tell what happened from logcat/dmesg because of bug 836505
> causing the log to be flooded.
> 
> Possibly related to bug 834059 and friends.
> 
> jlebar, if you know of work that might fix this please let me know / set dep
> here.

Please renominate this intermittent/edge issue for tef+ if the STR can't be worked around by going to the homescreen and re-opening Messages. For now, we'll track and fix for v1.x
blocking-b2g: tef? → -
tracking-b2g18: --- → ?
tracking-b2g18: ? → +
I can't seem to repro at this moment in time.  I did get OOMing to occur... having said that even with the OOM, things seem to open up just fine.

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_0/rev/6153fb8e61b6
Gaia   fa9e1b55dc1048d595617d14d41b7d57f696132b
BuildID 20130201070201
Version 18.0

Comment 4

6 years ago
Issue was unable to repro on build 20130208070201 Dec 5th Kernel
Opened up 5 different applications and had them running in the background before opening messages and it worked fine.  Messages opened correctly.
Tested again in unagi with Gecko-70c8f2c.Gaia-ecca2ee, and not able to reproduce it neither.
Keywords: qawanted
Component: DOM: Mozilla Extensions → DOM
Product: Core → Core
https://bugzilla.mozilla.org/show_bug.cgi?id=1472046

Move all DOM bugs that haven’t been updated in more than 3 years and has no one currently assigned to P5.

If you have questions, please contact :mdaly.
Priority: -- → P5
You need to log in before you can comment on or make changes to this bug.