Closed Bug 836677 Opened 11 years ago Closed 8 years ago

Copied link should be announced by a toaster notification

Categories

(Firefox for Android Graveyard :: General, enhancement)

ARM
Android
enhancement
Not set
normal

Tracking

(firefox21 affected, firefox22 affected, firefox23 affected, firefox30 affected, firefox31 affected, firefox32 affected, firefox33 affected, fennec-)

RESOLVED DUPLICATE of bug 1220556
Tracking Status
firefox21 --- affected
firefox22 --- affected
firefox23 --- affected
firefox30 --- affected
firefox31 --- affected
firefox32 --- affected
firefox33 --- affected
fennec - ---

People

(Reporter: teo.vermesan, Unassigned)

Details

Firefox 19.0b4 (2013-01-31)
Device: HTC Desire Z
OS: Android 2.3.3

Steps to reproduce:
1. Open Firefox for Android
2. Go to news.google.com
3. Long tap on a news article link
4. Select "Copy link".

Expected result:
- A toaster notification is triggered which confirms that the link is copied 

Actual result:
- After step 4, there isn't any notification triggered to confirm that the link was copied.

Notes: All other actions from context menu trigger this kind of confirmation
Why does an explicit chosen action need a notification? WONT-FIX?
Summary: Copied link should be announced by a pop-up → Copied link should be announced by a toaster notification
(In reply to Aaron Train [:aaronmt] from comment #1)
> Why does an explicit chosen action need a notification? WONT-FIX?

As I mentioned in the previous comment, all other actions from context menu trigger toaster notifications(e.g. when you add a  bookmark link, a notification is triggered: "Bookmark added". The same happens with "Open Link in New Tab")
fyi- If you long click the awesomebar then select |Copy Address|, it also copies to the clipboard without a toast message.
Issue is still reproducible on Aurora 22.0a2 2013-04-02 on the Acer Iconia Tab A500 (Android 3.2.1). Since there is a toaster notification when copying text to the clipboard I would expect to also be a notification for copied links.
Status: UNCONFIRMED → NEW
Ever confirmed: true
tracking-fennec: --- → ?
Ian - renom if you feel we need this.
tracking-fennec: ? → -
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.