If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Wrong display of window titles under MacOS (English)

RESOLVED DUPLICATE of bug 36689

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 36689
17 years ago
13 years ago

People

(Reporter: Jakub Formanek, Assigned: nhottanscp)

Tracking

({pp})

Trunk
PowerPC
Mac System 9.x

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
BuildID:  2001050518  

In case a US script is currently active in a MacOS, Mozilla is incapable of
displaying any other then ISO-8859-1 character in the title of a window.

If the title of the page is in a different language then english and
Mozilla runs with the US script active, only characters leading up to the first
non ISO-8859-1 character are displayed and the rest is truncated.

The page content is handled properly and is displayed in the correct charset.


Reproducible: Always
Steps to Reproduce:
1: Run any Mozilla (even localized builds) under MacOS US and load any page,
which has TITLE with non ISO-1 characters.

You can find an example at http://www.mozilla.cz/demo/

(Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9) Gecko/20010505)
also any 0.8.1 or older builds

Comment 1

17 years ago
confirm that I see this problem; problem is probably in widget/src/mac/
nsMacControl.cpp (nsMacControl::StringToStr255)

nhotta last touched this code; reassign to him.
Assignee: asa → nhotta
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: pp
(Assignee)

Comment 2

17 years ago
This is a dup of bug 36689 - Mac window title doesn't display non-ASCII 
characters when using US system.
I think SetWTitle assumes input as a system charset (e.g. MacRoman). If there is 
an API to take unicode then we want to use it. Or if we know about the charset 
of the document then we may map a charset to a script ID and temporary change a 
font of the graf port.

1078 NS_IMETHODIMP nsMacWindow::SetTitle(const nsString& aTitle)
1079 {
1080   Str255 title;
1081   // unicode to file system charset
1082   nsMacControl::StringToStr255(aTitle, title);
1083   ::SetWTitle(mWindowPtr, title);
1084   return NS_OK;
1085 }
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

17 years ago
reopen, it's a dup
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 36689 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

17 years ago
Well, probably window title is not affected by the current port setting, so
either need unicode API by Apple or need window title by xptoolkit.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.