Swipe no longer works in Firefox OS simulator

RESOLVED DUPLICATE of bug 836023

Status

Firefox OS
Gaia
RESOLVED DUPLICATE of bug 836023
5 years ago
5 years ago

People

(Reporter: Marco Perez, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
With GAIA profiles after commit 7a505331d9 (Bug #831656) the Firefox OS simulator
is virtually unusable. You can unlock the screen, but no swipes are recognized,
no matter how long or fast they're performed. Clicking on any of the icons on the
homescreen changes the color of that icon for as long as the mouse button is pressed,
but the apps won't start. Older profiles (commit b65af11afd or earlier) work fine.

Currently I have no device with a touch screen I could test it on. The tests were
performed with b2g trunk builds on FreeBSD 9-stable/amd64 with no patches applied
and using this mozconfig:

 CC=clang;      export CC
 CXX=clang++;   export CXX
 CPP=clang-cpp; export CPP
 
 GAIADIR=/work/gaia
 
 mk_add_options MOZ_OBJDIR="/work/build"
 mk_add_options MOZ_MAKE_FLAGS="-s -j4"
 
 ac_add_options --enable-application=b2g
 ac_add_options --disable-necko-wifi
 ac_add_options --disable-tests
 ac_add_options --disable-libjpeg-turbo
 ac_add_options --with-system-libevent=/usr/local

Can somebody confirm this for other platforms (especially tier-1) as well?
(Reporter)

Comment 1

5 years ago
BTW, I can to lower the "system bar" from the top (the one giving access to the WiFi, Bluetooth and Flight settings). And a right-click or long left-click with the mouse on the GAIA Homescreen activates the wallpaper menu.
This reminds me of bug 836023.  Perhaps it's a duplicate?
(Reporter)

Comment 3

5 years ago
Yes, I think so.
Unfortunately I looked for "swipe" only instead of "click" before filing this bug.

However, this seems to be fixed now. :-) \o/
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 836023
You need to log in before you can comment on or make changes to this bug.