If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 834372
5 years ago
5 years ago

People

(Reporter: Maël Lavault, Unassigned)

Tracking

({crash})

Trunk
ARM
Gonk (Firefox OS)
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2g-crash], URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 709028 [details]
Packaged app that trigger the crash.

Hi,

I've made a map application which works pretty well. I only have one problem :

On unagi device when doing a search on the app main screen, the app crash without explainations and sometimes make gaia restart as well. (There is no such problem in firefox desktop).

Here is what adb says :

D/memalloc(  107):  Out of PMEM. Dumping PMEM stats for debugging
D/memalloc(  107):  ------------- PRINT PMEM STATS --------------
D/memalloc(  107):  Node 0 -> Start Address : 0 Size 19200 Free info 0
D/memalloc(  107):  Node 1 -> Start Address : 19200 Size 19200 Free info 0
D/memalloc(  107):  Node 2 -> Start Address : 38400 Size 19200 Free info 0
D/memalloc(  107):  Node 3 -> Start Address : 57600 Size 19200 Free info 0
D/memalloc(  107):  Node 4 -> Start Address : 76800 Size 16640 Free info 0
D/memalloc(  107):  Node 5 -> Start Address : 93440 Size 2560 Free info 0
D/memalloc(  107):  Node 6 -> Start Address : 96000 Size 16640 Free info 0
D/memalloc(  107):  Node 7 -> Start Address : 112640 Size 2560 Free info 0
D/memalloc(  107):  Node 8 -> Start Address : 115200 Size 2560 Free info 0
D/memalloc(  107):  Node 9 -> Start Address : 117760 Size 2560 Free info 0
D/memalloc(  107):  Node 10 -> Start Address : 120320 Size 19200 Free info 1
D/memalloc(  107):  Node 11 -> Start Address : 139520 Size 16640 Free info 0
D/memalloc(  107):  Node 12 -> Start Address : 156160 Size 13312 Free info 1
D/memalloc(  107):  Node 13 -> Start Address : 169472 Size 2560 Free info 0
D/memalloc(  107):  Node 14 -> Start Address : 172032 Size 2560 Free info 0
D/memalloc(  107):  Node 15 -> Start Address : 174592 Size 2560 Free info 0
D/memalloc(  107):  Node 16 -> Start Address : 177152 Size 2560 Free info 0
D/memalloc(  107):  Node 17 -> Start Address : 179712 Size 475648 Free info 1
D/memalloc(  107):  Total Allocated: Total Free: 
D/memalloc(  107): ----------------------------------------------
E/memalloc(  107): /dev/pmem: No more pmem available
W/memalloc(  107): Falling back to ashmem

And also :

W/GraphicBufferAllocator(  656): alloc(2621440, 3358720, 1, 00000133, ...) failed -22 (Invalid argument)
I/Gecko   (  799): [Child 799] ###!!! ABORT: creating ThebesLayer 'back buffer' failed! width=2621440, height=3358720, type=3000: file ../../../gecko/gfx/layers/basic/BasicThebesLayer.cpp, line 460
E/Gecko   (  799): mozalloc_abort: [Child 799] ###!!! ABORT: creating ThebesLayer 'back buffer' failed! width=2621440, height=3358720, type=3000: file ../../../gecko/gfx/layers/basic/BasicThebesLayer.cpp, line 460
I/Gecko   (  656): 
I/Gecko   (  656): ###!!! [Parent][AsyncChannel] Error: Channel error: cannot send/recv
I/Gecko   (  656): 

The app is attached.

Updated

5 years ago
Component: General → Graphics
Product: Boot2Gecko → Core
Version: unspecified → Trunk

Updated

5 years ago
Severity: major → critical
Keywords: crash

Comment 1

5 years ago
It looks like bug 834372.
Blocks: 834372
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Whiteboard: [b2g-crash]

Updated

5 years ago
I'll put needs info on Andrew to conduct the review on this app. I'm guessing he'll hit the crash during the review.
Flags: needinfo?(awilliamson)
(Reporter)

Comment 3

5 years ago
any news on this ?
I'll look into this today.
Flags: needinfo?(awilliamson)
Keywords: qawanted
QA Contact: jsmith
(Reporter)

Comment 5

5 years ago
Did you find something ? It's kind of frustrating to have my app pending for review for so long because of a nasty bug ;)

Updated

5 years ago
Depends on: 840290
(In reply to mael.lavault from comment #5)
> Did you find something ? It's kind of frustrating to have my app pending for
> review for so long because of a nasty bug ;)

Tried to investigate, and then I hit bug 840290. Should be a quick fix on the marketplace side. Then, I can retry the investigation again.
(Reporter)

Comment 7

5 years ago
Have you made some progress since the UTF8 bug is fixed ? 

Thanks !
Yep, this app can be installed now.  We'll get it reviewed soon!
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Resolution: FIXED → WORKSFORME
(In reply to Lisa Brewster [:adora] from comment #8)
> Yep, this app can be installed now.  We'll get it reviewed soon!

Installed isn't what was causing the crash. It was during usage of the app that you would get a crash. If the crash stack Scoobidiver cites is the same as this crash, then it's likely this crash is still reproducing.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to Jason Smith [:jsmith] from comment #9)
> (In reply to Lisa Brewster [:adora] from comment #8)
> > Yep, this app can be installed now.  We'll get it reviewed soon!
> 
> Installed isn't what was causing the crash. It was during usage of the app
> that you would get a crash. If the crash stack Scoobidiver cites is the same
> as this crash, then it's likely this crash is still reproducing.

You would need to confirm that you can't reproduce the crash. Probably will either figured out by 1) completing the app review 2) I do some quick testing whenever I get to it.

Comment 11

5 years ago
Mael, are you able to reproduce the problem you described in comment 0?
Flags: needinfo?(mael.lavault)
My bad, mention of "the UTF bug" threw me off track.  With the submitted version, I got one app crash during search, but I've not been able to duplicate.
(In reply to Lisa Brewster [:adora] from comment #12)
> My bad, mention of "the UTF bug" threw me off track.  With the submitted
> version, I got one app crash during search, but I've not been able to
> duplicate.

Ah okay. Can you get a crash report ID with that crash you just got?
https://crash-stats.mozilla.com/report/index/bp-70957413-606f-40c2-934e-1f3f92130227
Okay, thanks. Looks like Scoobidiver is right - it's definitely a dupe of bug 834372.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Flags: needinfo?(mael.lavault)
Keywords: qawanted
Resolution: --- → DUPLICATE
Duplicate of bug: 834372

Updated

5 years ago
No longer blocks: 834372
You need to log in before you can comment on or make changes to this bug.