Closed Bug 840290 Opened 10 years ago Closed 10 years ago

The mini-manifests being generated for packaged apps for reviewers does not correctly parse UTF-8 characters in the mini-manifest

Categories

(Marketplace Graveyard :: Reviewer Tools, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
2013-02-14

People

(Reporter: jsmith, Assigned: robhudson)

References

Details

(Whiteboard: [MWCDemo2013])

The mini-manifests being generated for packaged apps does not correctly parse UTF-8 characters. Example that demonstrates this is Cartes (https://marketplace.firefox.com/reviewers/apps/review/cartes).

Mini-manifest:

{"name": "Cartes", "icons": {"60": "/img/icons/openmaps-60.png", "128": "/img/icons/openmaps-128.png"}, "version": "0.1", "package_path": "https://marketplace.firefox.com/reviewers/signed/cartes/1417600", "size": 141056, "release_notes": null, "locales": {"fr": {"description": "Une application bas\u0102\u0160e sur OpenStreetMap qui vous permet de trouver votre chemin.", "developer": {"url": "https://github.com/moimael/openmaps"}}}, "developer": {"url": "https://github.com/moimael/openmaps", "name": "Ma\u0102\u0164l Lavault"}}

Webapp manifest:

{
  "version": "0.1",
  "name": "Cartes",
  "description": "OpenStreetMap based application that let you find your way.",
  "launch_path": "/index.html",
  "icons": {
    "60": "/img/icons/openmaps-60.png",
    "128": "/img/icons/openmaps-128.png"
  },
  "developer": {
    "name": "Maël Lavault",
    "url": "https://github.com/moimael/openmaps"
  },
  "installs_allowed_from": ["*"],

  "locales": {
    "fr": {
      "description": "Une application basée sur OpenStreetMap qui vous permet de trouver votre chemin.",
      "developer": {
        "url": "https://github.com/moimael/openmaps"
      }
    }
  },
  "default_locale": "en",
  "type": "privileged",
  "permissions": {
    "systemXHR": {
      "description": "Required for search, route and map display"
    },
    "geolocation": {
      "description": "Required to display your location"
    }
  }
}

This is extremely important to fix - our target markets use UTF-8 characters in their languages, so not having this creates a problem in those respective locales, as you will not be able to install the app in those locales.
OS: Windows 7 → All
Hardware: x86_64 → All
Assignee: nobody → robhudson.mozbugs
Target Milestone: --- → 2013-02-14
Blocks: 837097
Duplicate of this bug: 840667
This bug puts a couple of MWC app demos at risk.
Whiteboard: [MWCDemo2013]
We had code that tried to guess the encoding of the manifest using chardet. In this case it was incorrectly guessing 'ISO-8859-2' resulting in badly encoded data. This patch updates to always use 'UTF-8' since that's what FirefoxOS does and also what the MDN docs say the Marketplace supports.

https://github.com/mozilla/zamboni/commit/fca485e
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.