Last Comment Bug 837131 - AWSY: ~4MB regression in explicit/resident memory usage on Fennec ARMv6
: AWSY: ~4MB regression in explicit/resident memory usage on Fennec ARMv6
Status: RESOLVED FIXED
[MemShrink]
: regression
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: general
Mentors:
Depends on:
Blocks: 828201
  Show dependency treegraph
 
Reported: 2013-02-01 07:37 PST by Kartikaya Gupta (email:kats@mozilla.com)
Modified: 2013-02-06 03:41 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
fixed


Attachments
About:memory diff (31.50 KB, text/plain)
2013-02-01 08:16 PST, Kartikaya Gupta (email:kats@mozilla.com)
no flags Details
Screenshot (178.76 KB, image/png)
2013-02-01 13:17 PST, Kartikaya Gupta (email:kats@mozilla.com)
no flags Details

Description Kartikaya Gupta (email:kats@mozilla.com) 2013-02-01 07:37:49 PST
See https://areweslimyet.com/mobile, and zoom in to circa 30 jan 2013. There is a 4.53 mb regression in startup resident memory usage; 3.87 mb in explicit memory usage. The regression range (from inbound builds) is:

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c669c3af96d4&tochange=009b00bcce30
Comment 1 Kartikaya Gupta (email:kats@mozilla.com) 2013-02-01 07:40:35 PST
Sorry, misread the graph data. 835178 is off the hook.
Comment 2 Andrew McCreight (PTO-ish through 6-29) [:mccr8] 2013-02-01 07:44:22 PST
Bug 835503 removes some debug-only code, so I doubt it is at fault.
Comment 3 Kartikaya Gupta (email:kats@mozilla.com) 2013-02-01 07:48:03 PST
The diff between the two about:memory reports shows that the largest difference comes from:

8077244 explicit
  2911848 explicit/workers (added)
    2911848 explicit/workers/workers() (added)
      2911848 explicit/workers/workers()/worker(resource:\\gre\modules\osfile\osfile_async_worker.js, 0x59496400) (added)

Looks like bug 828201 is the winner.
Comment 4 Justin Lebar (not reading bugmail) 2013-02-01 08:01:21 PST
Should we back out the offending cset?
Comment 5 David Bolter [:davidb] 2013-02-01 08:10:47 PST
What does "2911848 explicit/workers (added)" mean exactly?
Comment 6 Kartikaya Gupta (email:kats@mozilla.com) 2013-02-01 08:16:45 PST
Created attachment 709064 [details]
About:memory diff

It means that when comparing the "before" about:memory dump to the "after" about:memory dump, the total in the "explicit/workers" subtree went up by 2911848 bytes. The "(added)" means that the explicit/workers tree didn't even exist in the "before" dump. I've attached the full diff (as generated by my tool at https://github.com/staktrace/awsy-armv6/tree/master/about-memory-differ operating on the raw json files.
Comment 7 Geoff Brown [:gbrown] 2013-02-01 08:31:56 PST
There was a talos RSS regression at about the same time: bug 836429.
Comment 8 Nicholas Nethercote [:njn] (on vacation until July 11) 2013-02-01 12:46:41 PST
A nit:  when we file an AWSY regression bug can we please include a screenshot?
Comment 9 Kartikaya Gupta (email:kats@mozilla.com) 2013-02-01 13:16:07 PST
I backed out the offending change in https://hg.mozilla.org/integration/mozilla-inbound/rev/8728de36d4a8

My AWSY builder is catching up on some backlog so it hasn't run the backout yet; I will resolve this bug once that happens. Note that the talos RSS regression in bug 836429 was fixed by the backout.
Comment 10 Kartikaya Gupta (email:kats@mozilla.com) 2013-02-01 13:17:55 PST
Created attachment 709212 [details]
Screenshot
Comment 11 Kartikaya Gupta (email:kats@mozilla.com) 2013-02-02 18:20:07 PST
The AWSY website isn't showing the data yet, but the backout cset was processed, and it brought the resident memory down from 81399808 bytes to 77836288 bytes.

Note You need to log in before you can comment on or make changes to this bug.