[B2G][Settings Apps] Privacy policy – Firefox OS privacy policies directs to “404: Page not found “page.

VERIFIED WORKSFORME

Status

Firefox OS
Gaia::Settings
VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: sarsenyev, Assigned: jishnu)

Tracking

({smoketest})

unspecified
ARM
Gonk (Firefox OS)
smoketest

Firefox Tracking Flags

(blocking-b2g:tef+, b2g18 affected, b2g18-v1.0.0 wontfix, b2g18-v1.0.1 affected)

Details

(Whiteboard: testrun 5[npotb] inarirun1, leorun1)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
When you verify links and icons for Mozilla and partners, all links (Marketplace, everything.me) direct you to Privacy policies page, only Firefox OS link directs you to “404” page.
  
Build ID: 20130130070201
Kernel: Dec 5
Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/4593f3e765eb
Gaia   f7f5a0cd17e3d04308cc5850b254947e127122b9

Test case ID: 2670:
https://moztrap.mozilla.org/runtests/run/712/env/296/?pagenumber=1&pagesize=20&sortfield=order&sortdirection=asc&filter-id=2670

Steps to reproduce:
1. Update phone with build
2. Turn device ON
3. Tap “unlock” icon if it’s locked and slide right to see "Settings" icon
4. Tap “Settings” icon
5. Tap “Device information” under Device menu
6. Tap “Your Privacy” bar
7. Tap “Firefox OS” icon

Actual result:
Firefox OS link redirects to “404: Page not found” page.

Expected result:
Verify page includes links and icons to Privacy Policies for Mozilla and partners

Notes:
Repro'ed:
5/5

Updated

5 years ago
blocking-b2g: --- → tef?
Component: Gaia → Gaia::Settings

Comment 1

5 years ago
Hey Sid - we think this is the final URL for the Privacy policies page already. Can you set blocking-b2g to tef? if the current URL is not final?
blocking-b2g: tef? → -
Flags: needinfo?(sstamm)
https://www.mozilla.org/en-US/privacy/firefox-os is what it's trying to use on my phone (presumably locale-specific).
(Reporter)

Comment 3

5 years ago
This issue exists even on PC Mozilla Website, page cannot open, if the current URL is not final, the test case needs to be updated
Alex, I'm not the right guy for privacy policy links.  Tom: where will the firefox OS privacy policy live for in-product links?
Flags: needinfo?(sstamm) → needinfo?(tom)

Updated

5 years ago
Flags: needinfo?(tom) → needinfo?(jmenon)

Comment 5

5 years ago
Jishnu has been managing the implementation of privacy policies. He should have all the answers.

Comment 6

5 years ago
Issue also repros when being a first time user and going thru to Firefox OS Privacy Choices.  
Unagi
Build ID 20130222070201
Kernel Date: Dec 5
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/9df4d6efd664
Gaia: 5691a16fff8e1403c75ed9d6f3a443b7e58198c6

Comment 7

5 years ago
This issue's priority should be raised due to the high visibility of Mozilla's Privacy Policy not Viewable to the user.
blocking-b2g: - → leo?
(Assignee)

Comment 8

5 years ago
Hi guys,

Thanks for flagging. This is a known bug and I've been working on content and with our web dev team to get it up. Will post here when finished.
Flags: needinfo?(jmenon)
Whiteboard: testrun 4 → testrun 5
blocking-b2g: leo? → leo+
This is reproducible in 1.0.1, requesting tef blocking (again).
blocking-b2g: leo+ → tef?
Assignee: nobody → jmenon
blocking-b2g: tef? → tef+
status-b2g18: --- → affected
status-b2g18-v1.0.0: --- → wontfix
status-b2g18-v1.0.1: --- → affected
Whiteboard: testrun 5 → testrun 5[npotb]
(In reply to Jishnu Menon from comment #8)
> Hi guys,
> 
> Thanks for flagging. This is a known bug and I've been working on content
> and with our web dev team to get it up. Will post here when finished.

Is the current URL final? That's all we care about for the purposes of this bug.
Duplicate of this bug: 831252
Confirmed this is NPOTB with Jishnu, since the policy is serverside.

Updated

5 years ago
Keywords: smoketest
I think this is a dupe of bug 820212.
(Reporter)

Comment 14

5 years ago
These bug about a text implementation, this bug about no page opens , how come it’s a dupe?
(In reply to sarsenyev from comment #14)
> These bug about a text implementation, this bug about no page opens , how
> come it’s a dupe?

because the content on that FFOS privacy page you're redirecting to has not been created yet.  i believe the code to point to that URL is correct, it just needs bug 820212 to turn on live content.
Created attachment 729324 [details]
screenshot

what i see from comment 0.

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/dec694d585e1
Gaia   5a31a56b96a8fc559232d35dabf20411b9c2ca1d
BuildID 20130325070203
Version 18.0

Updated

5 years ago
Duplicate of this bug: 853921
I was going to dupe this to Bug 820212 but that bug doesn't have tracking flags set for the release. Given that we can leave this open until the text actually shows up on the page, and then close it out when it is up. As Tony notes in Comment 15 the 404 URL does point to correct page.
Also seen on Leo version 20130411070205
Kernel Date: Mar 15
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/f671fa539473
Gaia: e7e338a765e22334b40ced41489a785941382c66
Depends on: 820212

Updated

5 years ago
Whiteboard: testrun 5[npotb] → testrun 5[npotb] inarirun1

Updated

5 years ago
Whiteboard: testrun 5[npotb] inarirun1 → testrun 5[npotb] inarirun1, leorun1

Comment 20

5 years ago
Issue no longer repros on 
Unagi Build ID: 20130426070207
Kernel Date: Feb 21
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18_v1_0_1/rev/54285d67454b
Gaia: c47ef39de04e634d847cc86b6acc616fabce69eb

When user taps on Privacy from the Device information screen user is directed to Firefox Privacy Notice screen
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Resolution: FIXED → WORKSFORME

Comment 21

5 years ago
appears fine on v1-train as well,

FFOS privacy page has been created :)

Gecko  http://hg.mozilla.org/releases/mozilla-b2g18/rev/765d296cff66
Gaia   e420d71c9528786621f176fb4ce67d291e0a530e
Build  20130501070205
Version 18.0
Inari

Updated

5 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.