Closed Bug 837519 Opened 10 years ago Closed 10 years ago

Forums index is on Google

Categories

(support.mozilla.org :: Forum, task, P4)

Tracking

(Not tracked)

RESOLVED FIXED
2013Q1

People

(Reporter: cilias, Assigned: fxa90id)

References

()

Details

(Whiteboard: u=user c=questions p= s=2013.3 [mentor=r1cky])

There are often posts in the contributor forums from users looking for support. In a recent one [1], I asked how the user found the forum. He replied via private message, saying "I found the forum by googling something like "firefox support." "

"firefox support" does not bring up contributor forums, but "firefox support forum" does bring up https://support.mozilla.org/en-US/forums . We should probably prevent it from being indexed by Google.


[1]<https://support.mozilla.org/en-US/forums/lost-threads/708952>
Good point!
Priority: -- → P4
Whiteboard: u=user c=questions p= s=2013.3
Target Milestone: --- → 2013Q1
Assuming this is as simple as adding an item to the robots.txt, then this is probably a 1 pointer.
Whiteboard: u=user c=questions p= s=2013.3 → u=user c=questions p=1 s=2013.3
Moving to next sprint due to sprint being full.
Whiteboard: u=user c=questions p=1 s=2013.3 → u=user c=questions p=1 s=2013.4
Maybe somebody shows up soon? :)
Whiteboard: u=user c=questions p=1 s=2013.4 → u=user c=questions p=1 s=2013.4 [mentor=r1cky]
Assignee: nobody → michaljev
there is already {{ 1 }}/forums/ there. Maybe meta <meta name="robots" content="noindex"> would help ?
(In reply to Michał Frontczak :fxa90id from comment #5)
> there is already {{ 1 }}/forums/ there. Maybe meta <meta name="robots"
> content="noindex"> would help ?

Yeah, but that doesn't include https://support.mozilla.org/en-US/forums for example.
I wonder if doing:

Disallow: /{{ l }}/forums

is all we need?
(In reply to Ricky Rosario [:rrosario, :r1cky] from comment #7)
> I wonder if doing:
> 
> Disallow: /{{ l }}/forums
> 
> is all we need?

Yeah, from what I am reading here:
http://en.wikipedia.org/wiki/Robots.txt

it seems that we might just need to remove the trailing slash and be done?
but does {{ 1 }}/forums include {{ 1 }}/forums/ ?
oh you wrote it same time ;p I was thinking about removing / and should work I think :)
Deployed to prod now.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Moving this to the sprint it got fixed in.
Whiteboard: u=user c=questions p=1 s=2013.4 [mentor=r1cky] → u=user c=questions p= s=2013.3 [mentor=r1cky]
Depends on: 875889
Depends on: 883577
Oops, I typoed the bug number. Sorry about that.
No longer depends on: 875889, 883577
You need to log in before you can comment on or make changes to this bug.