Enable PulseAudio cubeb backend by default

RESOLVED FIXED in Firefox 28

Status

()

defect
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: kinetik, Assigned: kinetik)

Tracking

Trunk
mozilla28
All
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox28 fixed)

Details

(Whiteboard: [qa-])

Attachments

(1 attachment, 2 obsolete attachments)

Assignee

Description

6 years ago
Using PulseAudio as the default cubeb backend for Linux is the goal.  The ALSA backend will remain supported and the appropriate backend will be selected at runtime based on the host machine's capabilities.
Assignee

Updated

6 years ago
Depends on: 837564
Assignee

Comment 1

6 years ago
Most of this was done in bug 837564.  Once that lands, all that remains is to alter the build.

The build changes needed are: alter configure.in to use PulseAudio by default (and allow --disable-pulseaudio), remove PULSEAUDIO_LIBS from the libxul link, and possibly add an --enable-pulseaudio-link (or something) that does include PULSEAUDIO_LIBS in the libxul link for any other code that uses PulseAudio (WebRTC?)
Assignee

Updated

6 years ago
Assignee: nobody → kinetik
Status: NEW → ASSIGNED
Assignee

Comment 3

6 years ago
Posted patch bug837563_v0.patch (obsolete) — Splinter Review
Will see how it goes on Try before requesting review.
Assignee

Comment 4

6 years ago
Posted patch bug837563_v0.patch (obsolete) — Splinter Review
Let's try that again.

https://tbpl.mozilla.org/?tree=Try&rev=785ab040249c
Attachment #822126 - Attachment is obsolete: true
Assignee

Updated

6 years ago
Attachment #822130 - Attachment is obsolete: true
Assignee

Comment 7

6 years ago
Looks good on Try.

Enable PulseAudio by default in configure, remove existing -lpulse since in-tree uses dlopen libpulse when available.
Attachment #824970 - Flags: review?(mh+mozilla)
Comment on attachment 824970 [details] [diff] [review]
bug837563_v1.patch

Review of attachment 824970 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +5563,5 @@
> +
> +MOZ_ARG_DISABLE_BOOL(pulseaudio,
> +[  --disable-pulseaudio          Disable PulseAudio support],
> +   MOZ_PULSEAUDIO=,
> +   MOZ_PULSEAUDIO=1)

What is this supposed to achieve, if you remove MOZ_PULSEAUDIO_LIBS?
Attachment #824970 - Flags: review?(mh+mozilla)
Comment on attachment 824970 [details] [diff] [review]
bug837563_v1.patch

Review of attachment 824970 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +5563,5 @@
> +
> +MOZ_ARG_DISABLE_BOOL(pulseaudio,
> +[  --disable-pulseaudio          Disable PulseAudio support],
> +   MOZ_PULSEAUDIO=,
> +   MOZ_PULSEAUDIO=1)

Ah, saw comment 7.
Attachment #824970 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/6b6ea9376519
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
See Also: → 934290
Depends on: 934290

Comment 12

6 years ago
If building now requires libpulse-dev to be installed, this should be added to the documentation at
https://developer.mozilla.org/en-US/docs/Developer_Guide/Build_Instructions/Linux_Prerequisites
Assignee

Comment 13

6 years ago
(In reply to mjh563 from comment #12)
> If building now requires libpulse-dev to be installed, this should be added
> to the documentation

Thanks for the reminder, now done.
Assignee

Updated

6 years ago
Depends on: 934232
In the future, it would be nice if you made the configure error message tell the user what they need to do to work around this error (--disable-pulseaudio in this case).

Updated

6 years ago
Depends on: 952828
> In the future, it would be nice if you made the configure error message tell the user what
> they need to do to work around this error (--disable-pulseaudio in this case).

+1

Thanks for the PulseAudio support!
Actually, given that we have a fallback with ALSA, it shouldn't be a configure error, but a warning.
Filed bug 965653 to pass metadata to PulseAudio.
Whiteboard: [qa-]
Regression: Audio permanently broken when the Pulse server restarts. Filed bug 986985.
You need to log in before you can comment on or make changes to this bug.