Closed Bug 837670 Opened 8 years ago Closed 7 years ago

[Clock] "ready to use" perf measurement

Categories

(Firefox OS Graveyard :: Gaia::Clock, defect, P2)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED FIXED
1.4 S2 (28feb)

People

(Reporter: julienw, Assigned: mcav)

References

Details

(Keywords: perf, Whiteboard: [c=automation p= s=2014.02.28 u=][p=1])

Attachments

(1 file)

We need to measure when the app is usable by the user. For that we'll need to send an event (the moment is specific to the app) to |window| that the performance test will be able to receive.

The event name can be "x-moz-perf-user-ready" amongst all apps so that the performance test can be similar.

For the Clock, it should be triggered when the correct time is finally displayed.
No longer depends on: gaia-perf-measure
Summary: "ready to use" perf measurement → [CLock] "ready to use" perf measurement
Summary: [CLock] "ready to use" perf measurement → [Clock] "ready to use" perf measurement
Depends on: 837139
QA Contact: jshih → whsu
Any update? Thanks.
Who will in charge of the task?
It should not be difficult to do but someone has to do it. We're currently busy wuth other bugs.
Keywords: perf
Whiteboard: [c=instrumentation p=]
Priority: -- → P2
Whiteboard: [c=instrumentation p=] → [c=automation p= s= u=]
Assignee: nobody → mcav
Duplicate of this bug: 940306
Assignee: mcav → nobody
per :hub -- PerformanceTestingHelper.dispatch("startup-path-done") is usually what is being used
Assignee: nobody → m
Status: NEW → ASSIGNED
Target Milestone: --- → 1.4 S2 (28feb)
Whiteboard: [c=automation p= s= u=] → [c=automation p= s= u=][p=1]
Hey Mike, could you verify that this is the correct place to put the performance marker that says "the app is ready to use"?
Attachment #8380922 - Flags: review?(mike)
I think you also need to whitelist the app in /tests/performance/startup_events_test.js
Also the travis failure seems to be related.
Good catch, Julien and Hubert, thanks! Updated the PR, Travis passes.
Comment on attachment 8380922 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/16582

Hey Marcus,

Looks good to me. I've recommended a change that would require some additional code--see the pull request on GitHub. If you like that idea, then I'd be happy to re-review once you've implemented it. If you think it's out-of-scope for this bug, then file a separate bug for me to complete. Or, if you disagree, let me know why :)
Attachment #8380922 - Flags: review?(mike) → review+
Landed, with all fixes as suggested by Mike, Hubert, and Julien:

https://github.com/mozilla-b2g/gaia/commit/64c27638cadc7d4e3a629757a2dc54dd07f235d9
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [c=automation p= s= u=][p=1] → [c=automation p= s=2014.02.28 u=][p=1]
See Also: → 1015386
Duplicate of this bug: 1015386
You need to log in before you can comment on or make changes to this bug.