Valgrind tbpl builds are burning

RESOLVED FIXED in mozilla21

Status

()

Core
Build Config
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: gkw, Assigned: joey)

Tracking

Trunk
mozilla21
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
TEST-PASS | check-sync-dirs.py | /builds/slave/m-cen-lnx64-valgrind/src/js/src/build <= /builds/slave/m-cen-lnx64-valgrind/src/build
Generating ../src/js/src/configure using autoconf
cd ../src/js/src; /usr/bin/autoconf-2.13
make: *** No rule to make target `.mkdir.done', needed by `configure'.  Stop.
+ exit 2

Full log:
https://tbpl.mozilla.org/php/getParsedLog.php?id=19381993&tree=Firefox&full=1

Regression window:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=50cf5bbcb180&tochange=4e7c92906a79
Time to backout bug 830351 ?
Blocks: 830351
(Reporter)

Comment 2

5 years ago
Setting NEEDINFO from Joey since he coded the patch that landed in bug 830351.
Flags: needinfo?(joey)
(Assignee)

Comment 3

5 years ago
The catchall .mkdir.dep rule for creation w/o a directory prefix can be re-added and that should fix the problem.
Flags: needinfo?(joey)
(Assignee)

Comment 4

5 years ago
Created attachment 710858 [details] [diff] [review]
valgrind tbpl builds, re-add catchall mkdir dot rule
(Assignee)

Comment 5

5 years ago
(In reply to Joey Armstrong [:joey] from comment #4)
> Created attachment 710858 [details] [diff] [review]
> valgrind tbpl builds, re-add catchall mkdir dot rule

Testing locally and will send through for a review shortly.

NOTE: This failure hints that something may be attempting to create dot/cwd while sitting in cwd.  Directory dep w/o specifying the path to create may be an empty directory variable.
(Assignee)

Comment 6

5 years ago
Comment on attachment 710858 [details] [diff] [review]
valgrind tbpl builds, re-add catchall mkdir dot rule

Re-add the catchall mkdir dot/no directory prefix rule for valgrind/tbpl.
Attachment #710858 - Flags: review?(mh+mozilla)
Attachment #710858 - Flags: review?(mh+mozilla) → review+
(Assignee)

Updated

5 years ago
Assignee: nobody → joey
(Assignee)

Comment 7

5 years ago
Inbound push: committed changeset 121386:cff2fa817604
https://hg.mozilla.org/mozilla-central/rev/cff2fa817604
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla21
(Assignee)

Updated

5 years ago
Duplicate of this bug: 744750
You need to log in before you can comment on or make changes to this bug.