Enable Nokia test SUPL server for development builds

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: cjones, Assigned: kanru)

Tracking

unspecified
x86_64
Linux
Dependency tree / graph

Firefox Tracking Flags

(b2g18 fixed, b2g18-v1.0.1 fixed)

Details

Attachments

(1 attachment)

The server is test.supl.svc.ovi.com:7276.

Kan-Ru can you test this server?  I haven't been able to make SUPL connections through my provider :(.

We should ensure that this configuration isn't used for production builds; there should be an explicit flag set to enable this configuration.
(Assignee)

Updated

6 years ago
Duplicate of this bug: 813876
(Assignee)

Comment 2

6 years ago
Created attachment 710036 [details]
Pull request
Attachment #710036 - Flags: review?(fabrice)
Comment on attachment 710036 [details]
Pull request

Are we actually ok to ship the pref file? If so, this patch is ok. If not, we should just use custom-prefs.js
Attachment #710036 - Flags: review?(fabrice)
(Assignee)

Updated

6 years ago
Flags: needinfo?(jones.chris.g)
I don't think I understand fabrice's question.

We can't ship this file with production devices.  But we can and do want to distribute it in development builds.
Flags: needinfo?(jones.chris.g)
(Assignee)

Comment 5

6 years ago
Does dogfood count as production devices or development builds?
(Assignee)

Comment 7

6 years ago
Comment on attachment 710036 [details]
Pull request

Ask for review again given comment 6
Attachment #710036 - Flags: review?(fabrice)
Attachment #710036 - Flags: review?(fabrice) → review+
(Assignee)

Comment 8

6 years ago
Comment on attachment 710036 [details]
Pull request

[Approval Request Comment]

Dogfood only
Attachment #710036 - Flags: approval-mozilla-b2g18?

Updated

6 years ago
Attachment #710036 - Flags: approval-mozilla-b2g18?

Updated

6 years ago
Component: Builds → Gaia

Updated

6 years ago
Attachment #710036 - Flags: approval-gaia-v1+
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
v1-train: f8f45aca2d5565dc0a5005356695aed46dec0f32
status-b2g18: --- → fixed
status-b2g18-v1.0.1: --- → fixed
Keywords: checkin-needed
Batch edit: bugs fixed on b2g18 since 1/25 branch of v1.0 are fixed on v1.0.1
(Assignee)

Updated

6 years ago
Depends on: 850112
Hi, I think we should reconsider how the fix was done here.

I can see 2 possibilities :

* Fabrice's proposition in comment 3: Releng would add a local build/custom-prefs.js file in their build environment, and we backout what was commited here. This adds more work to the releng team though.

* We change the property to add this to (for example) SUPL_PREFS=1. I'd like to decorrelate DOGFOOD=1 with this, because DOGFOOD=1 is supposed to do much more. We could still make DOGFOOD=1 trigger SUPL_PREFS=1, but it would make it possible to add the prefs for the supl server in dev builds.

Fabrice, I'd love to know your opinion on this. I'd say the second way could be easier for everyone. If this is the way to do it, I'll go on with filing another bug and fixing this.
Flags: needinfo?(fabrice)
I'm not against adding something like SUPL_PREFS, even if I'm not a big fan. But I really think we should not make any env var trigger another one. Let's do everything explicitly, and not hidden behind some magic dependency.
Flags: needinfo?(fabrice)
I just found that the GPS prefs were recently moved to all builds in Bug 850112. So there is no need to do anything else here.
You need to log in before you can comment on or make changes to this bug.