[Music][User Story] Music search auto-hints

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Music
P2
normal
RESOLVED FIXED
5 years ago
3 years ago

People

(Reporter: pdol, Assigned: hub)

Tracking

({feature})

unspecified
2.1 S9 (21Nov)
ARM
Gonk (Firefox OS)
feature
Dependency tree / graph

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.2 fixed, relnote-b2g ?)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
UCID: Music-020

User Story:
As a user, I want to see my search to be auto-hinted as I type, so I don't have to type more than I have to when looking for a song.

Updated

5 years ago
Keywords: feature
Summary: [B2G][Music][User Story] Music search auto-hints → [Music][User Story] Music search auto-hints

Updated

5 years ago
Whiteboard: u=user c=music s=v1.1-sprint-1
Whiteboard: u=user c=music s=v1.1-sprint-1 → u=rmacdonald@mozilla.com c=music s=v1.1-sprint-1 p=0
Whiteboard: u=rmacdonald@mozilla.com c=music s=v1.1-sprint-1 p=0 → u=rmacdonald@mozilla.com c=music s=v1.1-sprint-1 p=.5
Whiteboard: u=rmacdonald@mozilla.com c=music s=v1.1-sprint-1 p=.5 → u=rmacdonald@mozilla.com c=music s=v1.1-sprint-1 p=0
UI specs updated and moved to dropbox:

https://www.dropbox.com/s/yepxm9hogne8apy/music-search.pdf

New version includes revisions to search field layout, transitions and additional information on what happens when the user taps on a search result.
Whiteboard: u=rmacdonald@mozilla.com c=music s=v1.1-sprint-1 p=0
Depends on: 844235
Clearing tracking-b2g18 flag from User Story bugs. This flag is for bugs that we would take fixes for in the 1.x branch. Feature work should be officially slotted into a release instead with leo+. If this story is intended for v1.1, please nominate for leo? blocking.
tracking-b2g18: + → ---
(Assignee)

Comment 4

4 years ago
(In reply to Rob MacDonald [:robmac] from comment #2)
> UI specs updated and moved to dropbox:
> 
> https://www.dropbox.com/s/yepxm9hogne8apy/music-search.pdf
> 
> New version includes revisions to search field layout, transitions and
> additional information on what happens when the user taps on a search result.

This document is missing (404). Where do we find the right one?

Thank you kindly.
Flags: needinfo?(rmacdonald)
Hi Hubert - I found that spec on my Mac but it's very out of date. Flagging Jacqueline (the current Music UX owner) as an fyi but is there something specific you're wondering about? - Rob
Flags: needinfo?(rmacdonald) → needinfo?(jsavory)
(Assignee)

Comment 6

4 years ago
Comment 1 has a link to a PDF, if that is still valid, I'll use that, it is sufficient.

Thanks
(Assignee)

Updated

4 years ago
Assignee: nobody → hub
(Assignee)

Updated

4 years ago
Target Milestone: --- → 2.1 S7 (24Oct)
(Assignee)

Updated

4 years ago
Blocks: 1018491
(Assignee)

Comment 7

4 years ago
Created attachment 8506172 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25191

Proposed fix. With tests. Will need a rebase when dependencies land
(Assignee)

Comment 8

4 years ago
Comment on attachment 8506172 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25191

Include patch for bug 1079349
Attachment #8506172 - Flags: review?(squibblyflabbetydoo)
(Assignee)

Updated

4 years ago
Target Milestone: 2.1 S7 (24Oct) → 2.1 S8 (7Nov)

Comment 9

4 years ago
Comment on attachment 8506172 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25191

I'm going to hold off on reviewing this until bug 1055043 lands and this is rebased. That bug is blocking all our future work on music, and I want Dominic to be able to land it ASAP.

Once bug 1055043 has landed and you've rebased this, please r? me again.
Attachment #8506172 - Flags: review?(squibblyflabbetydoo)
(Assignee)

Comment 10

4 years ago
I have rebased now. Will wait for landing to request review again.
(Assignee)

Updated

4 years ago
Depends on: 1055043
(Assignee)

Comment 11

4 years ago
Comment on attachment 8506172 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25191

Ok, this has been all rebased after the refactor landing.

Thank you kindly.
Attachment #8506172 - Flags: review?(squibblyflabbetydoo)
(Assignee)

Updated

4 years ago
Target Milestone: 2.1 S8 (7Nov) → 2.1 S9 (21Nov)

Comment 12

4 years ago
Comment on attachment 8506172 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25191

This looks good, aside from a couple of minor nits I posted about on GitHub. You may also want to get UI review before landing this.
Attachment #8506172 - Flags: review?(squibblyflabbetydoo) → review+
(Assignee)

Comment 13

4 years ago
Will address the nits. Thanks.
(Assignee)

Comment 16

4 years ago
Release Note Request (optional, but appreciated)
[Why is this notable]: UI change
[Suggested wording]: The search in the Music is now contextual depending on what's displayed.
[Links (documentation, blog post, etc)]:
relnote-b2g: --- → ?

Updated

4 years ago
feature-b2g: --- → 2.2+

Comment 17

4 years ago
Hub: I think we're generally supposed to squash all our commits into one before merging to make it easier for sheriffs to back things out if something broke. I don't think it's a huge deal here, but just for future reference.
(Assignee)

Comment 18

4 years ago
Comment on attachment 8506172 [details] [review]
Link to Github pull-request: https://github.com/mozilla-b2g/gaia/pull/25191

Jacqueline,

I got asked to put you as UI review. This UI change is currently in master (should appear in tomorrow nightly for 2.2). Not sure exactly what are the steps for UI review and if I got it backwards.

Thank you kindly.
Attachment #8506172 - Flags: ui-review?(jsavory)

Updated

3 years ago
See Also: → bug 1141705

Updated

3 years ago
Duplicate of this bug: 1018491
You need to log in before you can comment on or make changes to this bug.