Closed Bug 838121 Opened 10 years ago Closed 9 years ago

Export/import contact to/from memory card (in vcf format)

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:-, b2g18- fixed, b2g18-v1.0.1 affected)

RESOLVED FIXED
blocking-b2g -
Tracking Status
b2g18 - fixed
b2g18-v1.0.1 --- affected

People

(Reporter: kami911, Unassigned)

References

Details

No description provided.
There should be an easy way to export/import contacts in Firefox OS.
Bug 823492 is about yet another case for VCard/.vcf support. AFAIK, there's no chance to get this into v1 any more, but the good news is that the case here can fully be done in an app (using the Contacts and DeviceStorage APIs), and the bug 823492 case can mostly be done in an app - the missing link can apparently be hacked around as well, but the experience won't be as smooth as it can be (I'll comment there on that).
blocking-b2g: --- → leo?
tracking-b2g18: --- → ?
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
blocking-b2g: leo? → -
Not required for 1.1, but would be nice to have at some point for sure.
Minusing for tracking based on comment 3 - this should be renomed when it's in the scope of a particular version.
Assignee: nobody → sergi.mansilla
Assignee: sergi.mansilla → nobody
Duplicate of this bug: 824897
Judging by the title of bug 865999, this has been fixed already?
Flags: needinfo?(jmcf)
Hi!

AFAIK, we just added the import from the sdcard.

Cheers,
F.
Confirmed, can see import from SD card option in settings menu. In which case, I'll mark this as fixed - please reopen if I've gotten this wrong :)
Status: NEW → RESOLVED
Closed: 9 years ago
Flags: needinfo?(jmcf)
Resolution: --- → FIXED
Looks like bug 862742 did the import case (which is awesome), but this bug here requested both import and export. Should we leave this open for export or get a new one filed?
(In reply to Robert Kaiser (:kairo@mozilla.com) from comment #9)
> Looks like bug 862742 did the import case (which is awesome), but this bug
> here requested both import and export. Should we leave this open for export
> or get a new one filed?

I think a new bug, seeing as there's been activity on this one associated with import.
You need to log in before you can comment on or make changes to this bug.