kpmg.com - does not render correctly, layers sent by server-side sniffing

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
P1
major
RESOLVED FIXED
16 years ago
2 years ago

People

(Reporter: Sujit Mathew, Unassigned)

Tracking

Details

(Whiteboard: [aok] [proprietary-html] [proprietary-javascript], URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
The KPMG website does not render properly.

The Build ID i am using is 2001060120.
Could you be a little more specific? What renders wrong?  Screenshots would be 
nice.

This would be especially helpful because the site in question times out for me 
when I try to access it.
(Reporter)

Comment 2

16 years ago
When I enter http://www.kpmg.com, only the menus appear(HOME, GLOBAL SERVICES, 
ABOUT KPMG...etc) But there is no content however. In fact, none of the 
javascript works correctly either. For instance, the menu scroller. (the yellow 
rectangle which follows the mouse when you go over the menu.) Can anyone 
reproduce this?
If you scroll down you will see the content. The site is using "client sniffing"
and feeds Mozilla content that has <LAYER> elements. If you look at the
content that is fed to IE it's using absolutly positioned <DIV>s instead.
This is a site problem - not a bug in Mozilla.
Reassigning to Evangelism.
Assignee: asa → bclary
Component: Browser-General → Evangelism
QA Contact: doronr → zach
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Priority: -- → P1

Updated

16 years ago
Summary: KPMG website does not render correctly → kpmg.com - KPMG website does not render correctly

Comment 4

16 years ago
Contacted via web form 7/10/01.
Status: NEW → ASSIGNED

Updated

16 years ago
Summary: kpmg.com - KPMG website does not render correctly → kpmg.com - KPMG website does not render correctly (layers)

Comment 5

16 years ago
All Evangelism Bugs are now in the Product Tech Evangelism. See bug 86997 for
details.
Component: Evangelism → US English
Product: Browser → Tech Evangelism
Version: other → unspecified

Comment 6

16 years ago
follow up with these sites by 0.9.5
Target Milestone: --- → mozilla0.9.5

Comment 7

16 years ago
*** Bug 95305 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
-> 0.9.6, need to follow up on these asap
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Comment 9

16 years ago
Still no change as of build 2001110703
resetting bug, they now block us
Severity: normal → blocker
Status: ASSIGNED → NEW
Target Milestone: Nov → ---
actualy, they only block 6.x

Updated

16 years ago
Whiteboard: [aok]

Comment 12

16 years ago
*** Bug 126420 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
*** Bug 143893 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
*** Bug 132918 has been marked as a duplicate of this bug. ***

Comment 15

15 years ago
Just thought I'd add, as of today with the RC3 build (2002052306), www.kpmg.com
looks severely bad - :-( .  Fully none of the page is rendered properly -- looks
awful.  

Comment 16

15 years ago
This also affects the regional site kpmg.ca, and others I presume.
I hacked together a fix in about 2.5 hours; it can be found at 
http://www.meyerweb.com/eric/fixed/kpmg/index.html .  I didn't adjust the 
scrolling speed of any dynamic elements, so it does show the 
sluggishness of Mozilla at DHTML.  But the page renders "correctly" and 
acts as expected.  I'll be contacting them shortly with the same 
information.
Just a note that KPMG Consulting is now known as BearingPoint, and as such has a
new web presence: http://www.bearingpoint.com/index.asp

I'm guessing that the old domain of http://www.kpmg.com will use a META 302
redirect into the new URL.

The new site appears to work fine with Moz, though I haven't compared its DHTML
with IE.

Updated

15 years ago
Severity: blocker → major
OS: Windows 2000 → All
Hardware: PC → All
Summary: kpmg.com - KPMG website does not render correctly (layers) → kpmg.com - does not render correctly, layers sent by server-side sniffing
Whiteboard: [aok] → [aok] [proprietary-html] [proprietary-javascript]

Comment 19

15 years ago
*** Bug 150694 has been marked as a duplicate of this bug. ***

Comment 20

14 years ago
tech evang june 2003 reorg
Assignee: bc → english-us
QA Contact: zach → english-us

Comment 21

14 years ago
Created attachment 127172 [details]
This is how it looks in mozilla 1.4

Notice how the javascript menus are included in the main page

Comment 22

14 years ago
Created attachment 127173 [details]
What it looks like in ie 6

Comment 23

14 years ago
www.kpmg.com have updated their site and it doesnt seem to render at all in
Mozilla. I get a blank page and nothing else. Can anyone else confirm this?

NB: KPMG is a seperate company than BearingPoint
(In reply to comment #23)

I also get a blank page on Firefox-trunk and Netscape 7.1.

Comment 25

13 years ago
Me, too. kpmg.com does not render at all in Firefox 0.9
Still broken. It appears to do server-side browser sniffing and links a
different JavaScript depending on the user agent... except that the script it
links for Mozilla, /scriptlib/gk.js, doesn't actually exist. Ooops.

Comment 27

13 years ago
sent them an email+screenshot to webmaster@

Comment 28

13 years ago
From:	"US-KPMG Webmaster" <webmaster@kpmg.com>
Subject:RE: Major website issues when viewed with Mozilla & Firefox browsers
Date:	Fri, 17 Sep 2004 13:25:35 -0400

Currently, we only support Internet Explorer versions 5.5 and 6.0.
Thank you for your interest in KPMG and for your Service Inquiry. 

US-KPMG Webmaster

Comment 29

12 years ago
*** Bug 324935 has been marked as a duplicate of this bug. ***

Comment 30

10 years ago
This looks pretty much fixed in both Firefox 2 and Camino-trunk these days. I don't have WinIE around for comparison, but the site isn't really what I would call "broken" either.

Comment 31

10 years ago
I didn't look too close but the homepage includes object based detection and it appears ok with Firefox and BonEcho ua. -> FIXED. Thanks Chris.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.