Remove support for browser.download.panel.removeFinishedDownloads

RESOLVED FIXED in Firefox 20

Status

()

defect
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: mano, Assigned: mconley)

Tracking

(Blocks 1 bug)

Trunk
Firefox 21
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox20 verified)

Details

Attachments

(1 attachment)

See bug 836271. This preference should be removed.
Assignee: nobody → mconley
Blocks: 838681
Posted patch Patch v1Splinter Review
This patch removes the pref, and always overrides browser.download.manager.retention with 2 (always keep completed downloads).
Attachment #710785 - Flags: review?(mak77)
Comment on attachment 710785 [details] [diff] [review]
Patch v1

Review of attachment 710785 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #710785 - Flags: review?(mak77) → review+
https://hg.mozilla.org/mozilla-central/rev/54a885e14465
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
Comment on attachment 710785 [details] [diff] [review]
Patch v1

[Approval Request Comment]
Bug caused by (feature/regressing bug #): downloads panel feature
User impact if declined: nonsense preference with unpredictable behavior
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): minor, just removes a pref and ignores it
String or UUID changes made by this patch: none
Attachment #710785 - Flags: approval-mozilla-aurora?
Attachment #710785 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
having per-window private browsing fixes the issue
Verified as fixed on Firefox 20 beta 1 - as default the preference browser.download.panel.removeFinishedDownloads is not present in about:config and browser.download.manager.retention is set to 2.

Verified on Windows 7, Ubuntu 12.04 and Mac OS X 10.8:
Build ID: 20130220104816
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0
Firefox 20 does not have an option within the UI to remove completed downloads from the new download manager.

Additionally, due to this change, there is no config option to force the removal of finished downloads from the download manager.

There needs to be a replacement option for users that do not want to store download history at all; regardless of if it is cleared once the session ends.

See https://bugzilla.mozilla.org/show_bug.cgi?id=836271#c1 in https://bugzilla.mozilla.org/show_bug.cgi?id=836271 for an explanation.
(In reply to Ace Strife from comment #9)
> There needs to be a replacement option for users that do not want to store
> download history at all;

While I understand that such users exist (and I was one of them), we are still missing a valid use-case for which such option is actually useful for anything other than "I like empty lists".
If you have some use-cases where clearing downloads history on shutdown helps your productivity please report them in bug 838681.
A valid use-case ? Are you serious ? Would you like someone who has access to your computer to see everything that you have downloaded with a simple click ? That's what "Autoclear download history" is made for. It was a TERRIBLE choice to have removed it !!
(In reply to FireFoxFan from comment #11)
> A valid use-case ? Are you serious ? Would you like someone who has access
> to your computer to see everything that you have downloaded with a simple
> click ? That's what "Autoclear download history" is made for. It was a
> TERRIBLE choice to have removed it !!

That same person can just open your Downloads folder in the file system, or look at the history popup instead of the download manager. He would get the same exact data, even if the downloads manager is empty.
Btw, please notice replying to a 2 years old closed bug it's not the best way to bring up your concerns.
You need to log in before you can comment on or make changes to this bug.