Closed Bug 838676 Opened 9 years ago Closed 8 years ago

GetDisplayFileName() should only return the file name, not the file path

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla22

People

(Reporter: mounir, Assigned: mounir)

References

Details

Attachments

(1 file)

Attached patch PatchSplinter Review
No description provided.
Attachment #710775 - Flags: review?(jonas)
Component: HTML Form Controls → DOM: Core & HTML
Product: Camino → Core
Target Milestone: --- → mozilla22
https://hg.mozilla.org/mozilla-central/rev/efa7756f90a4
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
That's a very bad idea, causing usability regression. And here is absolutely no reason given why this decision is good.

Could you explain why you think the change is a good change, please? 

I do not know how you, but my disk contains several folders with exactly the same file names in there [1], but different content, and an ability to see that I'm going to upload a file from the right folder is the mandatory requirement. Please revert the change in the next release.

[1] $ find /usr/share/icons/ -name go-down.png | wc -l
    37
Having the full path wasn't working well because it wasn't readable at all and wasn't working for multiple files. I opened bug 891924 to get UX feedback on this issues though.
You need to log in before you can comment on or make changes to this bug.