Align the file name as expected when <input type='file'> has dir='rtl'

RESOLVED DUPLICATE of bug 762270

Status

()

Core
Layout: Form Controls
RESOLVED DUPLICATE of bug 762270
6 years ago
6 years ago

People

(Reporter: mounir, Assigned: mounir)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

6 years ago
Created attachment 710790 [details] [diff] [review]
Patch
Attachment #710790 - Flags: review?(smontagu)
(Assignee)

Updated

6 years ago
Blocks: 838675
Comment on attachment 710790 [details] [diff] [review]
Patch

Review of attachment 710790 [details] [diff] [review]:
-----------------------------------------------------------------

We definitely don't want to remove the "direction: ltr !important;" line. The right fix is to change "text-align: inherit" to "text-align: match-parent". This is in fact a dupe of bug 762270.
Attachment #710790 - Flags: review?(smontagu) → review-
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 762270
(Assignee)

Comment 3

6 years ago
(In reply to Simon Montagu from comment #1)
> Comment on attachment 710790 [details] [diff] [review]
> Patch
> 
> Review of attachment 710790 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> We definitely don't want to remove the "direction: ltr !important;" line.
> The right fix is to change "text-align: inherit" to "text-align:
> match-parent". This is in fact a dupe of bug 762270.

Could you point me to an example where having a rtl direction is wrong? I tried a few things and that seemed to work. Webkit seems to behave like that too.
You need to log in before you can comment on or make changes to this bug.