If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add visual touch feedback to entire tab row

VERIFIED FIXED in Firefox 20

Status

()

Firefox for Android
Theme and Visual Design
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: ibarlow, Assigned: sriram)

Tracking

unspecified
Firefox 21
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(firefox20 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 710830 [details]
mockup of change

Our new tab UI uses a border around the thumbnail to indicate that it's active. This is fine, but makes for a somewhat disconnected feeling when you touch anywhere else in the tab row and only the thumbnail is affected. 

Let's add a dark (30% black) background to the "touch" state.
(Assignee)

Comment 1

5 years ago
Created attachment 711471 [details] [diff] [review]
Patch

This changes the pressed state to be 30% black.
Attachment #711471 - Flags: review?(mark.finkle)
Attachment #711471 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 2

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/51ef9db638f0

Comment 3

5 years ago
https://hg.mozilla.org/mozilla-central/rev/51ef9db638f0
Assignee: nobody → sriram
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 21
(Assignee)

Comment 4

5 years ago
Comment on attachment 711471 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): Usability issue.
User impact if declined: No clear pressed state.
Testing completed (on m-c, etc.): Landed in m-c on 02/07
Risk to taking this patch (and alternatives if risky): Very low. Just a color change.
String or UUID changes made by this patch: None.
Attachment #711471 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #711471 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/da9d24b6b678

Updated

5 years ago
status-firefox20: --- → fixed

Comment 6

5 years ago
Verified using HTC Desire Z (Android 2.3.3) on: Nightly 21.0a1(2013-02-10) and Aurora 20.0a2(2013-02-10).
Status: RESOLVED → VERIFIED

Updated

5 years ago
status-firefox20: fixed → wontfix

Updated

5 years ago
status-firefox20: wontfix → verified
You need to log in before you can comment on or make changes to this bug.