Closed Bug 839232 Opened 8 years ago Closed 8 years ago

On 2/13, move pre-release CTP blocks to Firefox 20 and up

Categories

(Toolkit :: Blocklist Policy Requests, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
Tracking Status
firefox19 + verified
firefox20 --- verified

People

(Reporter: akeybl, Assigned: jorgev)

References

Details

On 2/13, let's move pre-release CTP blocks to Firefox 20 and up. From reviewing https://wiki.mozilla.org/Blocklisting/PluginBlocks, it would appear that would mean modifying p176 and p178.
Assignee: nobody → jorge
Both blocks have been modified on staging.
Assignee: jorge → nobody
Keywords: qawanted
QA Contact: anthony.s.hughes
Just to clarify:
* Firefox >=20 should CTP block Flash 11.0-11.4 and Flash <=10.3
* Firefox <=19 should not block Flash 11.0-11.4 and Flash <=10.3

Is this correct?
That's correct.
Firefox 19.0b5
* Flash 11.5.502.149 NOT BLOCKED
* Flash 11.3.300.273 NOT BLOCKED
* Flash 10.3.183.43 NOT BLOCKED

Firefox 20.0a2
* Flash 11.5.502.146 NOT BLOCKED
* Flash 11.4.402.278 CLICK TO PLAY
* Flash 10.2.159.1 CLICK TO PLAY

Based on these results I think it's safe to push this to production on February 13, 2013 as planned.
Keywords: qawanted
Jorge, looks like this might have been cleared accidentally but in either case let's keep it assigned to you until the bug resolved fixed.
Assignee: nobody → jorge
Updated in prod. Please verify.
Status: NEW → RESOLVED
Closed: 8 years ago
Keywords: qawanted
Resolution: --- → FIXED
The block in production does not appear to be working properly.

Firefox 19.0b6 w/Flash 10.2.159.1 is CTP blocked. The blocklist indicates min/max plugin version of 0 to 10.3.183.18.99, min/max Firefox version of 20.0a1 to *. Based on this it should be working.

I've tried uninstalling Firefox, deleting all "Mozilla" related folders under %appdata% and reinstalling Firefox. It remains CTP blocked when I believe it shouldn't.

Reopening to debug. Jorge, is this expected?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
After reinstalling, does the default blocklist.xml file have the previous block (19.0a1 and up), by chance?
(In reply to Jorge Villalobos [:jorgev] from comment #8)
> After reinstalling, does the default blocklist.xml file have the previous
> block (19.0a1 and up), by chance?

Yes...

blocklist.xml in C:\Program Files (x86)\Mozilla Firefox is 19.0a1 and up.
Before Ping:
* blocklist.xml in Program folder is 19.0a1+
* blocklist.xml in Profile folder does not exist

After Prod Ping:
* blocklist.xml in Program folder is 19.0a1+
* blocklist.xml in Profile folder is 20.0a1+
* Flash is CTP blocked

After Staging Ping:
* blocklist.xml in Program folder is 19.0a1+
* blocklist.xml in Profile folder is 20.0a1+
* Flash is NOT blocked
Alright, let's try this test:

1) Set up a new testing profile with Firefox 19 and an old version of Flash.
2) Point the blocklist URL to staging and force a blocklist ping.
3) Verify that Flash isn't blocked, as demonstrated in previous tests.
4) Close Firefox.
5) On the profile folder, delete pluginreg.dat and extensions.sqlite. Edit blocklist.xml so that the blocks are 19.0a1+
6) Start Firefox and verify that Flash is blocked.
7) Force a blocklist ping and test again.

If my suspicions are correct, Flash will continue to be blocked. What I'm thinking is that the blocklist code doesn't update the blocked status when the version range of a plugin block is changed.

If that's the case, a possible workaround would be to delete the current Flash blocks in prod, and reinstate them with the version range changed.
1. Start Firefox 19 with a new profile and Flash 10.2 installed
2. Load youtube.com
> Flash is CTP blocked

3. Point blocklist URL to staging and force a blocklist ping
4. Load youtube.com
> Flash is NOT blocked

5. Quit Firefox
6. Open the profile folder and delete pluginreg.dat, extensions.sqlite
7. Edit profile blocklist.xml so that p176 and p178 affect Firefox 19.0a1+
8. Start Firefox and go to youtube.com
> Flash is CTP blocked

9. Force a blocklist ping to staging
10. Load youtube.com
> Flash is NOT blocked

11. Verify the blocklist values in the profile blocklist.xml
> minVersion updated to 20.0a1
OK, can you repeat the test, but in the original step 5, after editing blocklist.xml, copy it to Program folder and delete it from the profile? That's the last thing I can think of that could be causing this difference.
1. Start Firefox 19 with a new profile and Flash 10.2 installed
2. Load youtube.com
> Flash is CTP blocked

3. Point blocklist URL to staging and force a blocklist ping
4. Load youtube.com
> Flash is NOT blocked

5. Quit Firefox
6. Open the profile folder and delete pluginreg.dat, extensions.sqlite
7. Edit profile blocklist.xml so that p176 and p178 affect Firefox 19.0a1+
8. Move profile blocklist.xml to Program folder, overwriting the Program blocklist and deleting the profile blocklist
9. Start Firefox and go to youtube.com
> Flash is CTP blocked

9. Force a blocklist ping to staging
10. Load youtube.com
> Flash is CTP blocked

Note the difference here...
* Leave program blocklist.xml, Flash is NOT blocked when pinging staging
* Overwrite program blocklist.xml, Flash is CTP blocked when pinging staging
Okay, it looks like the problem is somewhere else, and fortunately easier to fix.

CTP Block p260, for Flash 0 - 10.2.9999 (bug 832038) should only apply for 18.*. I got it right on staging but wrong when moving it to production, so it applied to 18.0a1 and all versions after that. I updated it just now so that it matches staging and its original intent.

So, now there are a couple of questions to resolve:

1) Do we want all Flash blocks to only work on 20 and up? In that case, I should just remove that block and we can retest in an hour or so to make sure everything's alright.

2) If (1) is a 'no', do we want to extend that block to cover 19.*? If that's the case, then I need to update the block, and we'll need to test with a version of Flash in the 10.3 branch or between 11.0 and 11.4.*.
Flags: needinfo?(akeybl)
OK, here's what we're doing:

p176 -> Firefox 20.0a1 - *, Flash 10.3 - 10.3.183.18.999
p260 -> Firefox 18.0a1 - *, 0 − 10.2.9999

This will remove the Flash version overlap that caused this confusion initially.
Flags: needinfo?(akeybl)
This should be fixed now. Please give an hour for the blocks to update.

So, we need to test the following:
* In Firefox 19, Flash 10.2.* and lower should be CTP blocked.
* In Firefox 19, Flash 10.3 - 10.3.183.18.999 should NOT be CTP blocked.
* In Firefox 19, Flash 11.0 - 11.4.402.286.999 should NOT be CTP blocked.
* In Firefox 20, Flash 10.2.* and lower should be CTP blocked.
* In Firefox 20, Flash 10.3 - 10.3.183.18.999 should be CTP blocked.
* In Firefox 20, Flash 11.0 - 11.4.402.286.999 should be CTP blocked.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
(In reply to Jorge Villalobos [:jorgev] from comment #17)
> * In Firefox 19, Flash 10.2.* and lower should be CTP blocked.
> * In Firefox 19, Flash 10.3 - 10.3.183.18.999 should NOT be CTP blocked.
> * In Firefox 19, Flash 11.0 - 11.4.402.286.999 should NOT be CTP blocked.
> * In Firefox 20, Flash 10.2.* and lower should be CTP blocked.
> * In Firefox 20, Flash 10.3 - 10.3.183.18.999 should be CTP blocked.
> * In Firefox 20, Flash 11.0 - 11.4.402.286.999 should be CTP blocked.

Verified all of these blocks are working as expected in production.
Status: RESOLVED → VERIFIED
Keywords: qawanted
Blocks: 851198
Product: addons.mozilla.org → Toolkit
You need to log in before you can comment on or make changes to this bug.