[SMS] Message app is broken on m-c build.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::SMS
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: Gene Lian (I already quit Mozilla), Assigned: borjasalguero)

Tracking

(Depends on: 1 bug, Blocks: 1 bug, {regression})

unspecified
ARM
Gonk (Firefox OS)
regression
Dependency tree / graph

Firefox Tracking Flags

(firefox21 affected, b2g18 unaffected)

Details

(Reporter)

Description

5 years ago
STR
==============================
  0. 2012/2/8 m-c Gecko build.

     changeset:   121190:eb8f60c782da
     tag:         tip
     user:        Jeff Muizelaar <jmuizelaar@mozilla.com>
     date:        Wed Feb 06 12:53:52 2013 -0500
     summary:     Bug 837715. Reduce compression rate for js source. r=benjamin

  1. Open the SMS app.
  2. Use another phone to send a SMS to our FFOS phone.

RESULTS
==============================
  1. The notification didn't show up no matter the Message app has been launched or not.
  2. Manually open the Message app and tap the new message. CANNOT check that message.

LOGCAT
==============================
I saw some Javascript errors as below:


E/GeckoConsole(  673): [JavaScript Error: "TypeError: contacts is null" {file: "app://sms.gaiamobile.org/js/sms.js" line: 979}]
E/GeckoConsole(  673): Content JS LOG at app://sms.gaiamobile.org/js/contacts.js:30 in onerror: Contact finding error. Error: undefined

NOTES
==============================
  1. The b2g18 is still working.
  2. Seems a Gecko issue because I only replaced the Gecko part with the m-c build.
(Reporter)

Comment 1

5 years ago
We need to fix this. Lots of MMS tasks are under way and rely on the Message app working.

CC'ing related people. I'm wondering something regarding the contact changes produces the above logcat error.

I'm sure it's not due to bug 831683 because it happened before my patches.
Keywords: regression, regressionwindow-wanted
(Reporter)

Updated

5 years ago
Duplicate of this bug: 841500
(Reporter)

Updated

5 years ago
Blocks: 709564

Comment 3

5 years ago
I was working on finding the regression window for this bug using the m-c builds and here is what I found—
1.	The last time the Notifications show up, was on the 2013-01-14-03-05-31 build. (The messages in the Inbox were still opening up tho).
2.	The last time the messages could be opened was on the 2013-01-24-16-28-01 build.
Keywords: regressionwindow-wanted
(Reporter)

Comment 4

5 years ago
Could any Gaia member please take a look on this bug? We cannot test the Message App with m-c build, where most of the Gecko engineers are working.

I guess there might be some Gecko modifications in the Contact stuff and the Message App doesn't handle the returned "null" properly. b2g-18 branches are not affected.
(Assignee)

Comment 5

5 years ago
I think that it's related with some changes in Contacts API. I will come back with more feedback.
(Assignee)

Updated

5 years ago
Assignee: nobody → fbsc

Comment 6

5 years ago
I have a look to this and I've seen the problem is regarding permissions. PermissionPromptHelper is not working properly and is denying the access when one of the permission is not requested. For contacts permission can be 'read', 'write' and 'create', as sms is requesting only read permission PermissionPromptHelper is denying the access to contacts.

As a workaround modifying permission from readonly to readwrite it will work until bug 804623 is resolved.

Updated

5 years ago
Depends on: 804623
(Assignee)

Comment 7

5 years ago
Thanks Albert! ;)
(Assignee)

Comment 8

5 years ago
Gene, Is SMS failing yet?
Flags: needinfo?(gene.lian)
(Reporter)

Comment 9

5 years ago
The work-around at comment #6 works for me. :) Thanks Albert and Borja!
Flags: needinfo?(gene.lian)
(Assignee)

Comment 10

5 years ago
Hi Gene, 
The thing is that... it's a workaround! What it means that with the code in 'master' Gaia & m-c Gecko it's not working at all... We need to fix the permission stuff in Gecko. Could you assign this bug to the one in charge of this? Thanks.
Flags: needinfo?(gene.lian)
(Reporter)

Comment 11

5 years ago
(In reply to Borja Salguero [:borjasalguero] from comment #10)
> Hi Gene, 
> The thing is that... it's a workaround! What it means that with the code in
> 'master' Gaia & m-c Gecko it's not working at all... We need to fix the
> permission stuff in Gecko. Could you assign this bug to the one in charge of
> this? Thanks.

Wait! Aren't we solving the Gecko part already at bug 804623? It seems Gregor is looking at that. For this bug here, we can apply the workaround on the Gaia end first. Does that sound reasonable to you?

Hi Steve, would you mind taking this task for the Gaia part?
Component: General → Gaia::SMS
Flags: needinfo?(gene.lian)
It's just a small change in manifest. Borja, do you agree to apply this workaround in master for MMS developing?
Flags: needinfo?(fbsc)
(Assignee)

Comment 13

5 years ago
I Steve. Despite of we could workaround this issue, I would like to wait until getting feedback from Gecko (due to they have detect where the bug is).
Flags: needinfo?(fbsc)
(In reply to Borja Salguero [:borjasalguero] from comment #13)
> I Steve. Despite of we could workaround this issue, I would like to wait
> until getting feedback from Gecko (due to they have detect where the bug is).

Bug 804623 landed. It should be fixed now if you update gecko and gaia.
Given the STR, this issue no longer exists
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.