Closed Bug 839735 Opened 8 years ago Closed 7 years ago

Intermittent b2g emulator reftest failures where the difference is a scrollbar not drawn: 478811-2.html, 478811-3.html, 478811-4.html, 637852-1.html, 331809-1.html,bug917595-exif-rotated.jpg

Categories

(Core :: Layout, defect, P5)

ARM
Gonk (Firefox OS)
defect

Tracking

()

RESOLVED FIXED
mozilla34
Tracking Status
firefox32 --- unaffected
firefox33 --- unaffected
firefox34 --- fixed
firefox-esr24 --- unaffected
firefox-esr31 --- unaffected
b2g-v1.4 --- wontfix
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: philor, Assigned: u459114)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files, 2 obsolete files)

Attached file reftest log
There are several more of these, but in every case the difference is that one of the two, test or reference, doesn't have a scrollbar drawn while the other does.

https://tbpl.mozilla.org/php/getParsedLog.php?id=19588351&tree=Firefox
b2g_ics_armv7a_gecko_emulator mozilla-central opt test reftest-4 on 2013-02-08 15:25:00 PST for push c1ee454506f6
slave: talos-r3-fed-054

15:43:41     INFO -  REFTEST TEST-START | http://10.0.2.2:8888/tests/layout/reftests/bugs/478811-4.html | 266 / 461 (57%)
15:43:41     INFO -  REFTEST TEST-START | http://10.0.2.2:8888/tests/layout/reftests/bugs/478811-4-ref.html | 266 / 461 (57%)
15:43:41     INFO -  REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/bugs/478811-4.html | image comparison (==), max difference: 102, number of differing pixels: 5850
...
15:43:51     INFO -  REFTEST INFO | Saved log: START http://10.0.2.2:8888/tests/layout/reftests/bugs/478811-4.html
15:43:51     INFO -  REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
15:43:51     INFO -  REFTEST INFO | Saved log: Initializing canvas snapshot
15:43:51     INFO -  REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
15:43:51     INFO -  REFTEST INFO | Saved log: [CONTENT] RecordResult fired
15:43:51     INFO -  REFTEST INFO | Saved log: RecordResult fired
15:43:51     INFO -  REFTEST INFO | Saved log: START http://10.0.2.2:8888/tests/layout/reftests/bugs/478811-4-ref.html
15:43:51     INFO -  REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
15:43:51     INFO -  REFTEST INFO | Saved log: Initializing canvas snapshot
15:43:51     INFO -  REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
15:43:51     INFO -  REFTEST INFO | Saved log: [CONTENT] RecordResult fired
15:43:51     INFO -  REFTEST INFO | Saved log: RecordResult fired
15:43:51     INFO -  REFTEST INFO | Loading a blank page

https://tbpl.mozilla.org/php/getParsedLog.php?id=19587268&tree=Mozilla-Inbound
b2g_ics_armv7a_gecko_emulator mozilla-inbound opt test reftest-4 on 2013-02-08 14:50:09 PST for push fc5e57e246e7
slave: talos-r3-fed-071

15:07:55     INFO -  REFTEST TEST-START | http://10.0.2.2:8888/tests/layout/reftests/bugs/478811-2.html | 264 / 461 (57%)
15:07:55     INFO -  REFTEST TEST-START | http://10.0.2.2:8888/tests/layout/reftests/bugs/478811-2-ref.html | 264 / 461 (57%)
15:07:55     INFO -  REFTEST TEST-UNEXPECTED-FAIL | http://10.0.2.2:8888/tests/layout/reftests/bugs/478811-2.html | image comparison (==), max difference: 102, number of differing pixels: 5850
...
15:08:16     INFO -  REFTEST INFO | Saved log: START http://10.0.2.2:8888/tests/layout/reftests/bugs/478811-2.html
15:08:16     INFO -  REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
15:08:16     INFO -  REFTEST INFO | Saved log: Initializing canvas snapshot
15:08:16     INFO -  REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
15:08:16     INFO -  REFTEST INFO | Saved log: [CONTENT] RecordResult fired
15:08:16     INFO -  REFTEST INFO | Saved log: RecordResult fired
15:08:16     INFO -  REFTEST INFO | Saved log: START http://10.0.2.2:8888/tests/layout/reftests/bugs/478811-2-ref.html
15:08:16     INFO -  REFTEST INFO | Saved log: [CONTENT] OnDocumentLoad triggering AfterOnLoadScripts
15:08:16     INFO -  REFTEST INFO | Saved log: Initializing canvas snapshot
15:08:16     INFO -  REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
15:08:16     INFO -  REFTEST INFO | Saved log: [CONTENT] RecordResult fired
15:08:16     INFO -  REFTEST INFO | Saved log: RecordResult fired
https://tbpl.mozilla.org/php/getParsedLog.php?id=19746983&tree=Mozilla-Inbound

Hello, Hello Kitty.
Summary: Intermittent b2g emulator reftest failures where the difference is a scrollbar not drawn: 478811-2.html, 478811-4.html → Intermittent b2g emulator reftest failures where the difference is a scrollbar not drawn: 478811-2.html, 478811-4.html, 637852-1.html
Andrew, don't suppose you could take a look? :-)
Blocks: b2g-reftest
Flags: needinfo?(ahalberstadt)
In general I don't really know much about the tests themselves, but it looks like ttaubert wrote all three. Tim do you have any insight to what might be happening here?
Flags: needinfo?(ahalberstadt) → needinfo?(ttaubert)
No, no. I merged those changes but e.g. 478811-4.html was written by bz :)
Flags: needinfo?(ttaubert) → needinfo?(bzbarsky)
That test looks fine to me; if there's a scrollbar in one of test+ref but not the other, that indicates a bug in whatever code decides to show the scrollbar...  The DOM should be identical in the test and ref once the load event runs.
Flags: needinfo?(bzbarsky)
(In reply to Boris Zbarsky (:bz) from comment #33)
> That test looks fine to me; if there's a scrollbar in one of test+ref but
> not the other, that indicates a bug in whatever code decides to show the
> scrollbar...

So shouldn't this bug be in Core/Layout? If not my apologies
Component: General → Layout
Product: Boot2Gecko → Core
Dunno.  This isn't happening on other platforms, and I'm not clear on how scrollbars work on b2g.
Duplicate of this bug: 834394
Summary: Intermittent b2g emulator reftest failures where the difference is a scrollbar not drawn: 478811-2.html, 478811-4.html, 637852-1.html → Intermittent b2g emulator reftest failures where the difference is a scrollbar not drawn: 478811-2.html, 478811-3.html, 478811-4.html, 637852-1.html
https://tbpl.mozilla.org/php/getParsedLog.php?id=20118384&tree=Mozilla-Inbound
Summary: Intermittent b2g emulator reftest failures where the difference is a scrollbar not drawn: 478811-2.html, 478811-3.html, 478811-4.html, 637852-1.html → Intermittent b2g emulator reftest failures where the difference is a scrollbar not drawn: 478811-2.html, 478811-3.html, 478811-4.html, 637852-1.html, 331809-1.html
Attached patch Disable tests (obsolete) — Splinter Review
I think this bug is a lot more prevalent than just these five tests. In order to get a green set of reftests running in the first place I had to disable hundreds of intermittent failures, most of which I didn't have time to investigate. I'd wager a large portion of them were due to this bug.

Anyway, going to disable these tests as there hasn't been much interest in fixing them.
Attachment #719022 - Flags: review?(jgriffin)
Attached patch Disable tests (2) (obsolete) — Splinter Review
Just noticed that bugs/530686-1.html also has this problem, updated patch to include it.
Attachment #719022 - Attachment is obsolete: true
Attachment #719022 - Flags: review?(jgriffin)
Attachment #719025 - Flags: review?(jgriffin)
Attachment #719025 - Flags: review?(jgriffin) → review+
Whiteboard: [leave-open] → [test disabled on b2g][leave-open]
Priority: -- → P5
https://tbpl.mozilla.org/php/getParsedLog.php?id=34861698&tree=Mozilla-Inbound
bug917595-exif-rotated.jpg
Summary: Intermittent b2g emulator reftest failures where the difference is a scrollbar not drawn: 478811-2.html, 478811-3.html, 478811-4.html, 637852-1.html, 331809-1.html → Intermittent b2g emulator reftest failures where the difference is a scrollbar not drawn: 478811-2.html, 478811-3.html, 478811-4.html, 637852-1.html, 331809-1.html,bug917595-exif-rotated.jpg
The underlying problem here should be fixed by bug 986404.
Depends on: 986404
Blocks: B2GRT
I think it's time to enable these 
== 331809-1.html 331809-1-ref.html R(5)
== 478811-2.html 478811-2-ref.html R(6)
== 478811-3.html 478811-3-ref.html R(6)
== 478811-4.html 478811-4-ref.html R(6)
== 530686-1.html 530686-1-ref.html R(7)
== 637852-1.html 637852-1-ref.html R(7)

https://tbpl.mozilla.org/?tree=Try&rev=de4edfa35e52
Wrong link again...sigh..

Here is the correct one
https://tbpl.mozilla.org/?tree=Try&rev=050267cef07e
Comment on attachment 8479169 [details] [diff] [review]
Enable test cases, which are disable because of scrollbar fade out effect

Hi Ahal,
Please help to review this patch, thanks
Attachment #8479169 - Flags: review?(ahalberstadt)
Comment on attachment 8479169 [details] [diff] [review]
Enable test cases, which are disable because of scrollbar fade out effect

Review of attachment 8479169 [details] [diff] [review]:
-----------------------------------------------------------------

Awesome, thanks once again!
Attachment #8479169 - Flags: review?(ahalberstadt) → review+
Keywords: checkin-needed
Whiteboard: [test disabled on b2g][leave-open] → [test disabled on b2g]
Attachment #719025 - Attachment is obsolete: true
Assignee: nobody → cku
https://hg.mozilla.org/mozilla-central/rev/d2f60a06625a
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
You need to log in before you can comment on or make changes to this bug.