Closed Bug 839908 Opened 8 years ago Closed 8 years ago

Thunderbird is extremely slow (10 seconds) in deleting pop account messages. Helped by clearing/deleting Trash. [McAfee]

Categories

(Thunderbird :: Folder and Message Lists, defect)

17 Branch
x86
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: r.en.h.etienne, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.0; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130116073211

Steps to reproduce:

All of a sudden Thunderbird started to be very slow. Perhaps it was an update (Windows or Thunderbird), but I don't know.
To resolve this I have looked extensively on the internet, and I have compacted folders, disabled add-ons, switched off virus scanners, worked in safe mode, installed office black theme, run Thunderfix, but nothing helps.
What about Thunderbird's safe mode https://support.mozilla.com/en-US/kb/Safe+Mode ?
(In reply to :aceman from comment #1)
> What about Thunderbird's safe mode
> https://support.mozilla.com/en-US/kb/Safe+Mode ?

As I said, I tried Safe Mode but it did not improve matters at all.
OK, so in which version of TB did the problem start? Does anything similar happen in Firefox? What kind of server do you use that has the problem (POP3/IMAP4)?
(In reply to :aceman from comment #3)
> OK, so in which version of TB did the problem start? Does anything similar
> happen in Firefox? What kind of server do you use that has the problem
> (POP3/IMAP4)?

I am running TB version 17.0.2. I am not sure what version it started with: I think I have had the problem for 2-3 weeks now, and I don't know whether TB did any automatic updates.
I am using POP3 and I don't have similar problems in Firefox.
I checked (under options - advanced - update - Show update history) and version 17.0.2 was installed on January 9. It might well t be that problems started then. (When I click "details", TB crashes after click close and OK).
Another thing that might be relevant: I have a problem with the Quick filter: it is very slow.
Which AV software do you use?

Please see https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems#Diagnosis_Steps and post your results.
I can confirm that you can fix this issue by excluding the thunderbird.exe process in microsoft security essentials, stopping it from scanning the process everytime it does something.

Recently windows updates started automatically installed MSE and whilst it's an amazing AV program it does cause slowness with certain processes.
(In reply to Wayne Mery (:wsmwk) from comment #6)
> Which AV software do you use?
Flags: needinfo?(r.en.h.etienne)
(In reply to Wayne Mery (:wsmwk) from comment #6)
> Which AV software do you use?
> 
> Please see
> https://wiki.mozilla.org/Thunderbird:Testing:
> Memory_Usage_Problems#Diagnosis_Steps and post your results.

McAfee. but turning it off did not help.
Flags: needinfo?(r.en.h.etienne)
(In reply to Robert Thompson from comment #7)
> I can confirm that you can fix this issue by excluding the thunderbird.exe
> process in microsoft security essentials, stopping it from scanning the
> process everytime it does something.
> 
> Recently windows updates started automatically installed MSE and whilst it's
> an amazing AV program it does cause slowness with certain processes.

No, this was not the problem. Instead, deleting the trash helped a lot.
Duplicate of this bug: 911543
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Rampal from comment #10)
> (In reply to Robert Thompson from comment #7)
> > I can confirm that you can fix this issue by excluding the thunderbird.exe
> > process in microsoft security essentials, stopping it from scanning the
> > process everytime it does something.
> > 
> > Recently windows updates started automatically installed MSE and whilst it's
> > an amazing AV program it does cause slowness with certain processes.
> 
> No, this was not the problem. Instead, deleting the trash helped a lot.

Please answer the following:
- how many messages were in trash?
- is speed now normal?
- if speed is not normal, does starting vista in safe mode help?
  http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/boot_failsafe.mspx
Flags: needinfo?(r.en.h.etienne)
Summary: Thunderbird is extremely slow (10 seconds) in deleting messages. → Thunderbird is extremely slow (10 seconds) in deleting pop account messages.
There were lots of messages in Trash.
Speed is now normal.
Flags: needinfo?(r.en.h.etienne)
(In reply to Rampal from comment #9)
> (In reply to Wayne Mery (:wsmwk) from comment #6)
> > Which AV software do you use?
> > 
> > Please see
> > https://wiki.mozilla.org/Thunderbird:Testing:
> > Memory_Usage_Problems#Diagnosis_Steps and post your results.
> 
> McAfee. but turning it off did not help.

aiui, there are actually two place McAfee hits 1) folders scanning 2) the addon/extension. So you might have only gotten one of them.

And fwiw, lots of reports of McAfee problems with version 24.

(In reply to Rampal from comment #13)
> There were lots of messages in Trash.
> Speed is now normal.

Thanks for that info. Yes, having tons of crash can make deletes very slow. You should empty trash at least once a week
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WORKSFORME
Summary: Thunderbird is extremely slow (10 seconds) in deleting pop account messages. → Thunderbird is extremely slow (10 seconds) in deleting pop account messages. Helped by clearing/deleting Trash. [McAfee]
You need to log in before you can comment on or make changes to this bug.