Test failure "The forward button has been made visible for the 1 page" in testToolbars/testBackForwardButtons.js

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: AndreeaMatei, Assigned: danisielm)

Tracking

unspecified
All
Mac OS X

Firefox Tracking Flags

(firefox21 wontfix, firefox22 wontfix, firefox23 wontfix, firefox27 fixed, firefox28 fixed, firefox29 fixed, firefox30 ?, firefox-esr24 fixed)

Details

(Whiteboard: [mozmill-test-failure], URL)

Attachments

(3 attachments, 11 obsolete attachments)

2.04 KB, patch
AndreeaMatei
: review-
Details | Diff | Splinter Review
1.51 KB, patch
AndreeaMatei
: review+
Details | Diff | Splinter Review
1.44 KB, patch
AndreeaMatei
: review+
Details | Diff | Splinter Review
(Reporter)

Description

6 years ago
This happened today after Jenkins was restarted, with Nightly fr locale - OS X 10.6.8.
Are the machines too fast now? The forward button appears to not have been visible.
(Reporter)

Updated

6 years ago
status-firefox21: --- → affected
Whiteboard: [mozmill-test-failure]
Happened today with Firefox 19.0b6 en-US candidate build:
http://mozmill-ci.blargon7.com/#/functional/report/a83c700664548dba07298b74bf099d0c
status-firefox19: --- → affected
(Reporter)

Comment 2

6 years ago
Hmm, thinking more about the issue in bug 832180 where we're too fast now, could be the same here. The forward button appears after there is a page to be forwarded to, so we either don't click the back button to have the forward button available or we move too fast:
http://hg.mozilla.org/qa/mozmill-tests/file/6692f287b545/tests/functional/testToolbar/testBackForwardButtons.js#l56
Have we been able to replicate this locally? Perhaps we could take one of the nodes offline to attempt to replicate this remotely. There have been no changes to Jenkins or the Mac nodes that should have affected this test. It only appears to be Mac 10.6.8, and is not locale specific.

Updated

6 years ago
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure] s=130218 u=failure c=toolbars p=1

Comment 4

6 years ago
Started happening on MAC 10.6.8 and Aurora branch:
http://mozmill-ci.blargon7.com/#/functional/report/a83c700664548dba07298b74bf9084e9
status-firefox20: --- → affected

Updated

6 years ago
Assignee: nobody → mario.garbi

Comment 6

6 years ago
Created attachment 718344 [details] [diff] [review]
patch v1.0

 I've added an expect.waitFor in order make sure the transition state is finished before checking in the assert.
Attachment #718344 - Flags: review?(andreea.matei)
(Reporter)

Comment 7

6 years ago
Comment on attachment 718344 [details] [diff] [review]
patch v1.0

Review of attachment 718344 [details] [diff] [review]:
-----------------------------------------------------------------

From what I understand, you couldn't reproduced it, but I would suggest to spend more time in doing that, on the machine shown in mozmill-ci reports. There's no guarantee this will work otherwise.
Also, the mini-macs are still slow now, so I'm not sure if this is a "speeding" issue.

::: tests/functional/testToolbar/testBackForwardButtons.js
@@ +52,5 @@
>    }
>  
> +  expect.waitFor(function () {
> +    return transitionFinished;
> +  }, "The transition has been finished");

This is also repeated in the assert from below.
Attachment #718344 - Flags: review?(andreea.matei) → review-
(Reporter)

Comment 8

6 years ago
One month without this failure, closing the bug.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME

Comment 9

6 years ago
Happened again with Firefox 22.0a2 it on Mac OS X 10.6.8 (x86_64):
http://mozmill-ci.blargon7.com/#/functional/report/25ad365ca7bcf4905e9b700b4fd28fc8

Reopening this and will look into it.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to mario garbi from comment #9)
> Reopening this and will look into it.

This bug has a very low frequency and doesn't require to spend time on it. Please care about the existent P1 bugs.
Priority: -- → P5
Why haven't we skipped this test yet on the affected branches? It's bouncing us for days now.
Priority: P5 → P2

Comment 12

5 years ago
Created attachment 734491 [details] [diff] [review]
Skip patch

Added a skip patch for the failing test until we can come with a fix to the issue.
Attachment #734491 - Flags: review?(andreea.matei)
Comment on attachment 734491 [details] [diff] [review]
Skip patch

Review of attachment 734491 [details] [diff] [review]:
-----------------------------------------------------------------

Given that this is only failing on OS X (right?), we should only skip it on this platform.

Comment 14

5 years ago
Created attachment 734497 [details] [diff] [review]
Skip patch for Mac OS
Attachment #734497 - Flags: review?(hskupin)
Attachment #734497 - Flags: review?(andreea.matei)

Comment 15

5 years ago
Added a skip patch for Mac only as requested, I should have done so in the first place, thank you Henrik.
(Reporter)

Comment 16

5 years ago
Comment on attachment 734497 [details] [diff] [review]
Skip patch for Mac OS

Review of attachment 734497 [details] [diff] [review]:
-----------------------------------------------------------------

::: tests/functional/testToolbar/testBackForwardButtons.js
@@ +63,5 @@
>      controller.waitForElement(element, TIMEOUT);
>    }
>  }
> +
> +if (mozmill.isMac){

Whitespace needed between brackets here.

@@ +65,5 @@
>  }
> +
> +if (mozmill.isMac){
> +  setupModule.__force_skip__ = "Bug 840022 - Test failure The forward button has been made" +
> +                             "visible for the 1 page";

Indentation please and a space in one of the strings so "made visible" don't get attached.

@@ +66,5 @@
> +
> +if (mozmill.isMac){
> +  setupModule.__force_skip__ = "Bug 840022 - Test failure The forward button has been made" +
> +                             "visible for the 1 page";
> +  testBackAndForward.__force_skip__ = "Bug 840022 - Test failure The forward button has been made" +

No need to skip this one as well, as it will be automatically because setup got skipped.
Attachment #734497 - Flags: review?(hskupin)
Attachment #734497 - Flags: review?(andreea.matei)
Attachment #734497 - Flags: review-
(Reporter)

Updated

5 years ago
Attachment #734491 - Attachment is obsolete: true
Attachment #734491 - Flags: review?(andreea.matei)
(Reporter)

Comment 17

5 years ago
Mario, also please edit the commit message, it should have capital letters and be more like "Skip test test.js due to failure.. ". Thanks.

Comment 18

5 years ago
Created attachment 734517 [details] [diff] [review]
Skip patch for Mac OS

 Added an updated version, sorry for those indentation issues, I was in a hurry to add a skip and overlooked them.
Attachment #734497 - Attachment is obsolete: true
Attachment #734517 - Flags: review?(andreea.matei)
(Reporter)

Comment 19

5 years ago
Comment on attachment 734517 [details] [diff] [review]
Skip patch for Mac OS

Review of attachment 734517 [details] [diff] [review]:
-----------------------------------------------------------------

I will edit the commit this time, please address all requests next time.

http://hg.mozilla.org/qa/mozmill-tests/rev/b7fe452034a9 (default)
Please check the patch with other affected branches.
Attachment #734517 - Flags: review?(andreea.matei) → review+
(Reporter)

Updated

5 years ago
status-firefox19: affected → ---
status-firefox22: --- → affected
status-firefox23: --- → disabled

Comment 20

5 years ago
The skip patch applies cleanly across all branches.
(Reporter)

Comment 21

5 years ago
Transplanted as:
http://hg.mozilla.org/qa/mozmill-tests/rev/7e244f990e13 (aurora)
http://hg.mozilla.org/qa/mozmill-tests/rev/2b12d4da3fff (beta)

I see no failures on ESR17.
status-firefox20: affected → ---
status-firefox21: affected → disabled
status-firefox22: affected → disabled

Comment 22

5 years ago
We attempted to reproduce the bug both on the local system and on the mm-osx-196-3 machine for almost a week now without any luck. I have used the builds that failed and tried to reproduce the conditions best I could.

Will try more this week to reproduce it in order to figure out the problem, if I still cannot get it to fail again I think we should unskip it and watch out for failures.
So lets reenable the test for nightly and we can see how often it fails. It's strange that no failures were visible for esr17. So it might be a regression in some way.
(Reporter)

Updated

5 years ago
status-firefox23: disabled → affected

Comment 25

5 years ago
We haven't seen this failure since we unskiped it. We could re-enable it for all branches and see if any fail in the future. I am still unable to reproduce it locally and it seems it doesn't reproduce anymore for the CI either.
(Reporter)

Comment 26

5 years ago
Backed out on aurora as well, let's see how this goes. 
http://hg.mozilla.org/qa/mozmill-tests/rev/6f47edec7840 (aurora)
(Reporter)

Updated

5 years ago
status-firefox22: disabled → affected
(Reporter)

Comment 27

5 years ago
No failures so I re-enabled the test on beta as well:
http://hg.mozilla.org/qa/mozmill-tests/rev/5ff06c2a431a (beta)

Lets give this a few days to check beta, before closing.
status-firefox21: disabled → affected

Comment 28

5 years ago
It did not reproduce since being unskipped, we could wait a few more days to be sure and close it.
(Reporter)

Comment 29

5 years ago
Closing as WFM, please reopen if necessary.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
status-firefox21: affected → wontfix
status-firefox22: affected → wontfix
status-firefox23: affected → wontfix
Resolution: --- → WORKSFORME

Comment 31

5 years ago
This started failing more often, we should reinvestigate and get a fix if possible.
Updated url:
http://mozmill-daily.blargon7.com/#/functional/failure?branch=All&platform=All&from=2013-07-26&test=%2FtestToolbar%2FtestBackForwardButtons.js&func=testBackForwardButtons.js%3A%3AtestBackAndForward
status-firefox24: --- → affected
status-firefox25: --- → affected
Priority: P2 → P1
(Reporter)

Comment 32

5 years ago
Mario, can you please reproduce on one failing machine if you can't locally? This is still a P2 as it's not failing each time but intermittently. It started again on August 1st, maybe something changed in the browser. 
We might want to skip this again and unskip it only with a fix. The skip patch is not applying anymore.
Priority: P1 → P2

Comment 33

5 years ago
It's still reproducing and I will add a skip patch in a few minutes.

Comment 34

5 years ago
Created attachment 785702 [details] [diff] [review]
skip_0508.patch

Updated Skip patch until I can come up with a Fix patch. This might be related to the Mac CI machine as I cannot reproduce it locally. I will test this on the failing machine too.
Attachment #734517 - Attachment is obsolete: true
Attachment #785702 - Flags: review?(andreea.matei)
(Reporter)

Comment 35

5 years ago
Comment on attachment 785702 [details] [diff] [review]
skip_0508.patch

Review of attachment 785702 [details] [diff] [review]:
-----------------------------------------------------------------

::: tests/functional/testToolbar/manifest.ini
@@ +1,2 @@
>  [testBackForwardButtons.js]
> +disabled = Bug 840022 - Test failure "The forward button has been made visible for the 1 page" in testToolbars/testBackForwardButtons.js

Please remove the test, it's already added above.
Attachment #785702 - Flags: review?(andreea.matei) → review-

Comment 36

5 years ago
Created attachment 785709 [details] [diff] [review]
skip_0508.patch

Updated the skip patch as requested
Attachment #785702 - Attachment is obsolete: true
Attachment #785709 - Flags: review?(andreea.matei)
(Reporter)

Comment 37

5 years ago
Comment on attachment 785709 [details] [diff] [review]
skip_0508.patch

Review of attachment 785709 [details] [diff] [review]:
-----------------------------------------------------------------

Landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/268fa396a2b6 (default)
http://hg.mozilla.org/qa/mozmill-tests/rev/6d9c05b7f35f (aurora)
Attachment #785709 - Flags: review?(andreea.matei) → review+
Why has this test been disabled on OS X in the test but for all platforms in the manifest? This is not clear to me.
Flags: needinfo?(mario.garbi)
Whiteboard: [mozmill-test-failure] s=130218 u=failure c=toolbars p=1 → [mozmill-test-failure][mozmill-test-skipped]
status-firefox25: affected → disabled
status-firefox26: --- → disabled

Comment 39

5 years ago
We only had this on OS X so I should have skipped it for OS X only in the manifest too. I will provide a followup skip patch to change that.
Flags: needinfo?(mario.garbi)

Comment 40

5 years ago
Created attachment 792047 [details] [diff] [review]
skip_1908.patch

Followup skip patch to only skip for mac in the manifest. I didn't knew about skip-if since we don't use it in out manifests so thanks Henrik for noticing this. I will use this from now on for the manifests.
(Reporter)

Comment 41

5 years ago
Comment on attachment 792047 [details] [diff] [review]
skip_1908.patch

Review of attachment 792047 [details] [diff] [review]:
-----------------------------------------------------------------

This is way off, please check the patch again cause you've added the skip again when it's supposed to be just a follow up for the manifest. 
Also you need to update the commit message and request review next time :)
Attachment #792047 - Flags: review-

Comment 42

5 years ago
Created attachment 792225 [details] [diff] [review]
skipFollowup.patch

Sorry about the previous patch, wrong patch uploaded.
Attachment #792047 - Attachment is obsolete: true

Updated

5 years ago
Attachment #792225 - Flags: review?(andreea.matei)
(Reporter)

Comment 43

5 years ago
Comment on attachment 792225 [details] [diff] [review]
skipFollowup.patch

Review of attachment 792225 [details] [diff] [review]:
-----------------------------------------------------------------

::: tests/functional/testToolbar/manifest.ini
@@ +1,3 @@
>  [testBackForwardButtons.js]
>  disabled = Bug 840022 - Test failure "The forward button has been made visible for the 1 page"
> +skip-if = os == "mac"

This will skip the test regardless of the platform due to the disable line. I remember I've done one skip like this and I used the message after the 'mac'.

Please see: 
https://pypi.python.org/pypi/ManifestDestiny/0.5.6 
and test this with 2.0, running the manifest, to make sure it does what's supposed to.
Also let's use single quotes.
Attachment #792225 - Flags: review?(andreea.matei) → review-

Comment 44

5 years ago
Created attachment 793373 [details] [diff] [review]
skipFollowup_2108.patch

Correct followup patch, thank you Andreea.
Attachment #792225 - Attachment is obsolete: true
Attachment #793373 - Flags: review?(andreea.matei)
(Reporter)

Comment 45

5 years ago
Comment on attachment 793373 [details] [diff] [review]
skipFollowup_2108.patch

Review of attachment 793373 [details] [diff] [review]:
-----------------------------------------------------------------

::: tests/functional/testToolbar/manifest.ini
@@ +1,2 @@
>  [testBackForwardButtons.js]
> +skip-if = os == "mac" = Bug 840022 - Test failure "The forward button has been made visible for the 1 page"

Still missing the single quotes I mentioned.
Attachment #793373 - Flags: review?(andreea.matei) → review-

Comment 46

5 years ago
Created attachment 795325 [details] [diff] [review]
skipFollowup_2508.patch

Changed to single quotes as requested, I will provide a fix patch as soon as I am able.
Attachment #793373 - Attachment is obsolete: true
Attachment #795325 - Flags: review?(andrei.eftimie)
Attachment #795325 - Flags: review?(andreea.matei)
(Reporter)

Comment 47

5 years ago
Comment on attachment 795325 [details] [diff] [review]
skipFollowup_2508.patch

Review of attachment 795325 [details] [diff] [review]:
-----------------------------------------------------------------

Landed followup:
http://hg.mozilla.org/qa/mozmill-tests/rev/6ae7cc15c140 (default)
http://hg.mozilla.org/qa/mozmill-tests/rev/0105774d9354 (aurora)
Attachment #795325 - Flags: review?(andrei.eftimie)
Attachment #795325 - Flags: review?(andreea.matei)
Attachment #795325 - Flags: review+

Comment 48

5 years ago
I have tried to reproduce this on the failing CI machine after removing the skip but I wasn't able to. Could this be related to certain platform issues? In order to be sure that we aren't getting this anymore could we back-out the skip patch for Default?

Comment 49

5 years ago
I tried again today to reproduce it but I am still not able. I took offline the mm-osx-106-2 machine and ran 300 times the test using mozmill -t for the folder testToolbar.

Comment 50

5 years ago
Lets reenable this test once we have mozmill 2.0 running in CI
(Reporter)

Comment 51

5 years ago
Mario, when you have a spare machine, please check if this still reproduces with 2.0.3. Thanks.

Comment 52

5 years ago
I have unskipped and tested this on a local Mac machine and the issue doesn't reproduce anymore. I think it would be safe to unskip.

http://mozmill-crowd.blargon7.com/#/functional/reports?branch=All&platform=Mac&from=2014-01-13&to=2014-01-13
(Reporter)

Comment 53

5 years ago
Daniel, could you please check if this is safe to unskip and if so prepare a patch? When you have some spare time. I can't backout cause it had follow up patch as well. Thanks!
Assignee: mario.garbi → daniel.gherasim
Status: REOPENED → ASSIGNED
(Assignee)

Comment 54

5 years ago
Created attachment 8371520 [details] [diff] [review]
unskip_testBackForwardButtons.patch

In 105 runs it didn't fail once on latest nightly:

http://mozmill-crowd.blargon7.com/#/functional/reports?branch=30.0&platform=Mac&from=2014-02-06&to=2014-02-06

Unskip patch provided.
Attachment #785709 - Attachment is obsolete: true
Attachment #795325 - Attachment is obsolete: true
Attachment #8371520 - Flags: review?(andreea.matei)
(Reporter)

Comment 55

5 years ago
Please be careful about the commit message, it should describe the patch (in this case enabling a test) and have the reviewers added. Thanks

Enabled:
http://hg.mozilla.org/qa/mozmill-tests/rev/4e10acdf95ca (default)
status-firefox24: affected → ---
status-firefox25: disabled → ---
status-firefox27: --- → disabled
status-firefox28: --- → disabled
status-firefox29: --- → disabled
status-firefox30: --- → fixed
(Reporter)

Comment 56

5 years ago
Comment on attachment 8371520 [details] [diff] [review]
unskip_testBackForwardButtons.patch

Review of attachment 8371520 [details] [diff] [review]:
-----------------------------------------------------------------

Forgot to change the flag. Let's check the other branches as well if nothing fails on default.
Attachment #8371520 - Flags: review?(andreea.matei) → review+
(Assignee)

Updated

5 years ago
Attachment #8379609 - Flags: review?(andrei.eftimie)
Attachment #8379609 - Flags: review?(andreea.matei)
(Assignee)

Comment 58

5 years ago
Created attachment 8379646 [details] [diff] [review]
enableTestBackForwardButtons_beta.patch

Beta:

http://mozmill-crowd.blargon7.com/#/functional/reports?app=All&branch=28.0&platform=Mac&from=2014-02-21&to=2014-02-21
Attachment #8379646 - Flags: review?(andrei.eftimie)
Attachment #8379646 - Flags: review?(andreea.matei)
(Reporter)

Comment 59

5 years ago
There was no need for the new patches, you should've just checked if the nightly patch applies.

Transplanted:
http://hg.mozilla.org/qa/mozmill-tests/rev/dfe91a9223fa (aurora)
http://hg.mozilla.org/qa/mozmill-tests/rev/fc2a7f1eaf51 (beta)

Release and ESR24 are left.
status-firefox28: disabled → fixed
status-firefox29: disabled → fixed
(Reporter)

Updated

5 years ago
Attachment #8379646 - Attachment is obsolete: true
Attachment #8379646 - Flags: review?(andrei.eftimie)
Attachment #8379646 - Flags: review?(andreea.matei)
(Reporter)

Updated

5 years ago
Attachment #8379609 - Attachment is obsolete: true
Attachment #8379609 - Flags: review?(andrei.eftimie)
Attachment #8379609 - Flags: review?(andreea.matei)
(Assignee)

Comment 60

5 years ago
Created attachment 8381257 [details] [diff] [review]
enableTestBackForwardButtons_esr.patch

Previous patch applies cleanly on RELEASE.

REPORT:
http://mozmill-crowd.blargon7.com/#/functional/reports?app=All&branch=27.0&platform=All&from=2014-02-22&to=2014-02-25

--

For ESR24, the previous patch doesn't apply as we have different manifest.ini file.

REPORT
http://mozmill-crowd.blargon7.com/#/functional/reports?app=All&branch=24.3&platform=All&from=2014-02-25&to=2014-02-25
Attachment #8381257 - Flags: review?(andreea.matei)
(Reporter)

Comment 61

5 years ago
Comment on attachment 8381257 [details] [diff] [review]
enableTestBackForwardButtons_esr.patch

Review of attachment 8381257 [details] [diff] [review]:
-----------------------------------------------------------------

http://hg.mozilla.org/qa/mozmill-tests/rev/cd1037310422 (release)
http://hg.mozilla.org/qa/mozmill-tests/rev/abc280f5d110 (esr24)

Please don't forget to also add the bug no. in the commit message.
Attachment #8381257 - Flags: review?(andreea.matei) → review+
(Reporter)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago5 years ago
status-firefox26: disabled → ---
status-firefox27: disabled → fixed
status-firefox-esr24: --- → fixed
Resolution: --- → FIXED
Whiteboard: [mozmill-test-failure][mozmill-test-skipped] → [mozmill-test-failure]
(Reporter)

Comment 62

5 years ago
Failed twice today with Nightly de and it, both on 10.9.2 os x:
http://mozmill-daily.blargon7.com/#/functional/report/a438ea29b921b2e8124749eda95f10ea
http://mozmill-daily.blargon7.com/#/functional/report/a438ea29b921b2e8124749eda9605175

Daniel, could you check on that machine?
Status: RESOLVED → REOPENED
status-firefox30: fixed → affected
Resolution: FIXED → ---
(Reporter)

Comment 63

5 years ago
Hm, not sure if related to that machine anymore. Failed once on 10.7.5, aurora de:
http://mozmill-daily.blargon7.com/#/functional/report/3ed2024184b13bf096824c08080ca4f0
(Assignee)

Comment 66

4 years ago
No failure in the last month with this.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
status-firefox30: affected → fixed

Comment 67

4 years ago
I wouldn't mark 30 as fixed since we didn't change anything in particular to address the issue.
status-firefox30: fixed → ?
You need to log in before you can comment on or make changes to this bug.