Assertion failure: false (The number of items in sClassInfoData doesn't match the number of nsIDOMClassInfo ID's, this is bad! Fix it!), at /home/mikeh/dev/mozilla/m-c/inbound-src/dom/base/nsDOMClassInfo.cpp:3648

RESOLVED DUPLICATE of bug 840260

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 840260
5 years ago
5 years ago

People

(Reporter: mikeh, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Build inbound-src:d509e44cae3e with B2G_DEBUG=1 causes assertion failure and crash loop on startup.  Logcat context:

E( 4443:0x115b) Could not read chrome manifest 'file:///system/b2g/chrome.manifest'.
I( 4443:0x1167) WARNING: NS_ENSURE_TRUE(lowMemFd != -1) failed: file /home/mikeh/dev/mozilla/m-c/inbound-src/widget/gonk/GonkMemoryPressureMonitoring.cpp, line 136
I( 4443:0x115b) WARNING: Failed to create Addons Manager.: file /home/mikeh/dev/mozilla/m-c/inbound-src/toolkit/xre/nsXREDirProvider.cpp, line 799
F( 4443:0x115b) Assertion failure: false (The number of items in sClassInfoData doesn't match the number of nsIDOMClassInfo ID's, this is bad! Fix it!), at /home/mikeh/dev/mozilla/m-c/inbound-src/dom/base/nsDOMClassInfo.cpp:3648
F( 4443:0x115b) Fatal signal 11 (SIGSEGV) at 0x00000000 (code=1)
I( 4442:0x115a) debuggerd committing suicide to free the zombie!
I( 4457:0x1169) debuggerd: Feb 11 2013 10:47:10
This crash does not happen for B2G_DEBUG=0 builds.
    if (i != eDOMClassInfoIDCount) {
      printf_stderr("i = %d, eDOMClassInfoIDCount = %d\n", i, eDOMClassInfoIDCount);
      MOZ_NOT_REACHED("The number of items in sClassInfoData doesn't match the "
                      "number of nsIDOMClassInfo ID's, this is bad! Fix it!");

      return NS_ERROR_NOT_INITIALIZED;
    }

I( 7591:0x1da7) i = 320, eDOMClassInfoIDCount = 321
Andrea, it looks your change m-c:92f93ab32aec is causing the run-time check in Comment 2 (above) to fail on DEBUG builds.

This change is described as "Bug 838172 - Convert AudioChannelManager to WebIDL", and it removes the following lines from nsDOMClassInfo.cpp:

    2.35 -#ifdef MOZ_AUDIO_CHANNEL_MANAGER
    2.36 -  NS_DEFINE_CLASSINFO_DATA(AudioChannelManager, nsEventTargetSH,
    2.37 -                           EVENTTARGET_SCRIPTABLE_FLAGS)
    2.38 -#endif

But the declaration still exists in nsDOMClassInfoClasses.h:

432 #ifdef MOZ_AUDIO_CHANNEL_MANAGER
433 DOMCI_CLASS(AudioChannelManager)
434 #endif

If this is an unintentional leftover, I can remove it.
Flags: needinfo?(amarchesini)
This doesn't affect any of the mozilla-b2g18 branches because they haven't picked up the change yet.
Created attachment 712591 [details] [diff] [review]
remove leftover AudioChannelManager reference from nsDOMClassInfoClasses.h
Attachment #712591 - Flags: review?(amarchesini)
This patch is perfect but this bug is a duplicate of 840260.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(amarchesini)
Resolution: --- → DUPLICATE
Duplicate of bug: 840260
Attachment #712591 - Flags: review?(amarchesini)
You need to log in before you can comment on or make changes to this bug.