Flicker of white on transitions

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Settings
RESOLVED WORKSFORME
5 years ago
2 years ago

People

(Reporter: cjones, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

Firefox Tracking Flags

(Not tracked)

Details

STR
 (1) Open settings
 (2) Tap "Device information"

See flicker of white before transition.

 (3) Tap "More information"

See another flicker of white.

 (4) Tap "Developer"

Another flicker of white.

 (5) Tap "<"

No flicker of white.

b? -> radar
I've been building with inbound all day.  Grr.  This is only an issue on m-c.
blocking-b2g: tef? → ---
Holy annoying, batman.
Occurs: 2013-02-01-03-10-00_MC_unagi
Slightly different behavior in 2013-01-01-03-04-13_MC_Unagi : white flash + slide appears
Quick flash + slide still happens in 2012-12-13-03-08-11... 

That's as far back as releng builds go...
Mercurial-Information: 
"mozilla-central" revision="edd45de440ba"
"integration/gaia-nightly" revision="79bfd32e008d"

Looks like we've had this white flash for a long time : bug 808216
Do you want me to bisect where it got slower?
Flags: needinfo?(jones.chris.g)
Did it get significantly slower in the intervals above?  I don't recall whether I saw that when I filed this bug :/.

If the regression is that old, I'm pretty sure I know what caused it.

I would recommend staying on v1.0 stuff if you have any, but if your plate is clear, sure that'd be great! :)
Flags: needinfo?(jones.chris.g)
I think it's more of a judgement call.  The first time you go through the settings, it will be slower, once you get past the first time, it does pick up.  There is a slight pause more on the repeats for the 2/26 build than in the 2/15 build.

2/1 : http://www.youtube.com/watch?v=hirZvs7Tx2s&feature=youtube_gdata_player
2/15 : http://www.youtube.com/watch?v=fCEbRrhk_pE&feature=youtube_gdata_player
2/26 : http://www.youtube.com/watch?v=46H6uykf1MQ&feature=youtube_gdata_player

I'll leave it to you as the reporter to decide if I should pursue this further.
Flags: needinfo?(jones.chris.g)
Let's focus on 1.0.
Flags: needinfo?(jones.chris.g)
Blocks: 864272

Comment 6

5 years ago
Issue reproduced on Unagi, Build ID: 20121213030811
Gecko: http://hg.mozilla.org/mozilla-central/rev/edd45de440ba 

I do not have access to builds older than that to test for the regression window.
Keywords: regressionwindow-wanted
works fine in recent build
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.