http uploads send file as complete path, it should be just filename

VERIFIED DUPLICATE of bug 44464

Status

()

Core
HTML: Form Submission
VERIFIED DUPLICATE of bug 44464
17 years ago
17 years ago

People

(Reporter: mattyt, Assigned: Eric Pollmann)

Tracking

({helpwanted, qawanted})

Trunk
mozilla0.9.2
x86
Linux
helpwanted, qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [http-upload])

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19 i586; Nav)
BuildID:    2001060115

When I am composing a new message or replying to an existing one, I click the
browse button to find the file I want to attach, double-click the file, then
click Attach.  The file shows up with the complete path as opposed to simply the
name of the file itself.  For instance, it is attached and sent as
/home/mattyt/foobar.jpg instead of simply foobar.jpg.  The recipient is unable
to open the file they receive.

Reproducible: Always
Steps to Reproduce:
1. Log in to my IMP webmail system 
2. Compose new message
3. Click the attach button
4. Double-click the file I want to attach
5. Click Attach
6. Click Send
7. The file cannot be opened by the recipient

Actual Results:  The file is not usable by the recipient

Expected Results:  Should have sent the file as 'foobar.jpg' instead of
'/home/mattyt/foobar.jpg'

Updated

17 years ago
Assignee: asa → neeti
Component: Browser-General → Networking: HTTP
QA Contact: doronr → benc
Whiteboard: [http-upload]

Comment 1

17 years ago
um. i dunno is there a spec for http-upload?

Comment 2

17 years ago
this is the first bug I've seen since I signed up.

anyone got any pointers?
Keywords: qawanted

Comment 3

17 years ago
*** Bug 85577 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
it's a code bug. when most browsers send a file as part of an upload, they send 
the filename, when we send the full path. it should be really easy to fix. I'd 
say bug 85577's location is probably easier to use 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: helpwanted
Summary: attachments when using IMP webmail show up with complete path, not just filename → http uploads send file as complete path, it should be just filename

Comment 5

17 years ago
-> pollmann (?)
Assignee: neeti → pollmann
Component: Networking: HTTP → Form Submission
(Assignee)

Comment 6

17 years ago
Is this a Linux only problem?  Both Nav 4.75 and IE 5.5 on Win32 send the full
file path, so we are compatible there.

Would it be possible for you to attach a URL and temporary account info where I
can test the "IMP" webmail system?  Thanks.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.2
(Assignee)

Comment 7

17 years ago
FWIW, I think bug 85577 is really a dup of bug 83065, which is why I removed the
URL above, and changed what it was marked a dup of.  See reasoning on that bug.

(Assignee)

Comment 8

17 years ago
This will be fixed with the patch on bug 44464.  Marking dup.

*** This bug has been marked as a duplicate of 44464 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
QA Contact: benc → vladimire

Comment 9

17 years ago
verifying per developer's coments
Status: RESOLVED → VERIFIED
(Assignee)

Comment 10

17 years ago
*** Bug 94634 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 11

17 years ago
See converse duplicates on bug 59408
You need to log in before you can comment on or make changes to this bug.