Closed Bug 84030 Opened 20 years ago Closed 19 years ago

Click on "Gosling talks Duke" link - hangs browser

Categories

(Core Graveyard :: Java: OJI, defect)

x86
Windows NT
defect
Not set
critical

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: twolf, Assigned: joe.chou)

References

()

Details

(Keywords: crash, hang)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9+) Gecko/20010603
BuildID:    2001060320

www.javasoft.com has a Java applet.  Clicking on links on
that page (at least the ones I've tried) causes the
browser to hang.

Reproducible: Always
Steps to Reproduce:
1. Go to www.javasoft.com (with Java enabled)
2. Click on "Gosling talks Duke..." link.



Actual Results:  Hangs browser - need to kill with Task Manager and restart.

Expected Results:  See the page requested:
http://www.javasoft.com/features/2001/06/goslingduke.html?frontpage-se

I seem to remember that hitting the "Back" button from www.javasoft.com
actually causes an Application fault - as I'm writing this from
within Mozilla, I can't check :-)
Keywords: hang
WFM on 2001060409 on Win2K with Java enabled.

Thomas, could you try this again using a talkback build, and post the talkback ID?
Thanks a lot!
After getting your e-mail, I immediately went and picked up the talkback
version and installed it....But then I realized - what good will the
talkback version do since Mozilla didn't actually crash: it just hangs!
Is there a way in Windows NT that I can cause it to crash - and produce
the stack trace you're presumably looking for? (i.e. something akin to
"kill -11" in UNIX.)

Thanks,
Tom

P.S.  One encouraging thing: it still hangs with the newer talkback
version - so the bug had the decency to hang around [:-)]
Worksforme with today's Monday's linux trunk built debug enabled, and jdk1.3.1.

Ed
Since Ed's Linux build from today worked, I tried the latest Windows version
(2001/06/05-04).  It still hangs.  Figuring that, perhaps, it's one of those
mysterious crashes that disappears when you remove various moz* files from
the Winnt directory, I did that and repeated the experiment.  Same result:
it hangs when clicking on a link from that Java containing page.
(Interestingly, it doesn't use any more CPU than normal - just sits there
as if in the middle of a transfer with the Mozilla icon no longer updating and
the cursor with a busy indicator.)

My complete environment: Build 2001060504 on WinNT 4.0 SP5; JRE 1.3.1; 256MB
RAM
Thomas,

D'oh!  I realized after writing that comment that you in fact said Hang, not 
Crash.  My mistake.

Sometimes when Mozilla hangs for me it eventually crashes after gobbling up 
memory for a while (it may take some time with the 256MB you have).  Is this 
the case?

Thanks for grabbing the new talkback build!
No, it doesn't consume any more resources when it hangs - it's just stuck.
CPU utilization doesn't go up, memory usage doesn't either.  The 'hanging'
also affects the JRE (1.3.1) - I can't bring up the Java console either.

Again, does someone with Windows expertise know how to crash an application
so that we can get a stack trace of where it got stuck?

tom
That page just hangs for me as, without needing to click a link. 2001-06-09 
Win95. It's fine with Java turned off.

Gerv
I have been getting this problem on Linux for months... Mozilla used to be the
most stable Java browser on Linux... I really dont know what's causing this, but
its very annoying... I had the same as bug 86196.
I believe this is a dupe of bug 85041.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.1+) Gecko/20010620

I get the same results as Gerv. (Direct crash with Java enabled on 
www.javasoft.com and java.sun.com)
confirmed on win95 june 25th build
Assignee: asa → edburns
Status: UNCONFIRMED → NEW
Component: Browser-General → OJI
Ever confirmed: true
Keywords: crash
QA Contact: doronr → shrir
Marking NEW based on confirmation. lets try OJI since it crashes with Java enabled.
this is the lazy java startup thing..which is going to stay as it is(browser 
appears frozen for a while..then whole page appears). Reporter...pls try to 
visit some other applet page (you would see same behaviour). .but once the jvm 
loads, if u visit another page..it hould laod fine..
Shrirang suggested that this might be a 'lazy Java startup' issue.  The behaviour
others describe certainly may have their cause in the Java startup, but they're
not the same problem as I had encountered: in my case, Java had already started
up!  It's only when I visited the next link (in particular the link to the
Gosling story that since then has been removed from www.javasoft.com) that the
browser would hang.

I just tried going to www.javasoft.com with the 070108 nightly.
The page loads and the applet runs as before. I then
manually entered the URL to the Gosling story (since I can't click the link
anymore.)  The browser no longer hangs.  Should I assume that the problem was
somehow fixed and close this bug?  What's the procedure?

Thanks,
Tom
Seems to work with 10 July 01 Trunk and 0.9.2. branch.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
QA Contact: shrir → pmac
SPAM: reassigning OJI bugs to new QA, pmac. (227 bugs)
Chris Petersen is a new QA contact for oji component. His email is:
petersen@netscape.com
Assignee: edburns → petersen
change to the assigned to joe chou
Status: RESOLVED → REOPENED
QA Contact: pmac → petersen
Resolution: WORKSFORME → ---
change back to resolved-workforme
Status: REOPENED → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → WORKSFORME
.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
resolved-workforme
Assignee: petersen → joe.chou
Status: REOPENED → NEW
resolved-workforme
Status: NEW → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → WORKSFORME
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.