Unreadable text on notification Facebook panel

RESOLVED INVALID

Status

()

Firefox
SocialAPI
RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: virgil, Unassigned)

Tracking

Trunk
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 713411 [details]
Unreadable text on facebook notification panel

Reproducible on Firefox 19.0 Beta 6 (20130212082553): Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Reproducible on latest Aurora (20130213042019): Mozilla/5.0 (X11; Linux x86_64; rv:20.0) Gecko/20130213 Firefox/20.0
Reproducible on latest Nightly (20130213031137): Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20130213 Firefox/21.0


Steps to reproduce:
1. Turn on Facebook Messenger for Firefox from https://www.facebook.com/about/messenger-for-firefox
2. Log in with your account
3. Click on the notification buttons to view the list of notifications/messages/friends 


Expected result:
Notifications/messages/friend request should be readable.

Actual result:
Unreadable text on the notification panel.

Searching for regression range.
Can you provide more details about what distribution, desktop environment, and theme you are using?
Please also check if this happens in Firefox 17 or 18 to determine if it's a recent regression. And it would be useful to know if you have HWA turned on. Please provide a copy of the graphics section of about:support.
(Reporter)

Comment 3

5 years ago
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #1)
> Can you provide more details about what distribution, desktop environment,
> and theme you are using?

Forgot to mention Ubuntu 12.04 LTS 64-bit whit a new clean profile, no themes or add-ons installed.

(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #2)
> Please also check if this happens in Firefox 17 or 18 to determine if it's a
> recent regression. And it would be useful to know if you have HWA turned on.
> Please provide a copy of the graphics section of about:support.

17.0.1 (20121128204232) is worst because the menu has opacity 0 and you can actually see trough the panel what's behind it.
and 18.0.2 (20130201065344) has the same issue as in 19.0 to Latest Nightly.

This is the result from mozregression
Last good nightly: 2012-10-18
First bad nightly: 2012-10-19

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cb573b9307e5&tochange=0ff60bfb3442

The issue also happens with HWA off.

Graphics
Adapter Description - ATI Technologies Inc. -- ATI Radeon HD 5450
Device ID - ATI Radeon HD 5450
Driver Version - 4.2.11627 Compatibility Profile Context
GPU Accelerated Windows - 0/1 Basic 
Vendor ID - ATI Technologies Inc.
WebGL Renderer - ATI Technologies Inc. -- ATI Radeon HD 5450
AzureCanvasBackend - cairo
AzureContentBackend - none
AzureFallbackCanvasBackend - none
(Reporter)

Comment 4

5 years ago
The text is also unreadable in /messages/notification panel for the Ubuntu 12.04.1 LTS 32-bit.
Hardware: x86_64 → All
(In reply to Virgil Dicu [:virgil] [QA] from comment #3)
> 17.0.1 (20121128204232) is worst because the menu has opacity 0 and you can
> actually see trough the panel what's behind it.
> and 18.0.2 (20130201065344) has the same issue as in 19.0 to Latest Nightly.
> 
> This is the result from mozregression
> Last good nightly: 2012-10-18
> First bad nightly: 2012-10-19
> 
> Pushlog:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=cb573b9307e5&tochange=0ff60bfb3442

I'm not certain about this regression range (Firefox 19 Nightly) if the issue is reproducible and worse going back to Firefox 17.

Does someone on the SocialAPI Development team have any ideas?
FWIW, I'm unable to reproduce this on my Ubuntu 64bit VM:
  Application Basics
        Name        Firefox
        Version        21.0a1
        User Agent        Mozilla/5.0 (X11; Linux x86_64; rv:21.0) Gecko/20130213 Firefox/21.0

...
  Graphics

        Adapter Description
        VMware, Inc. -- Gallium 0.4 on llvmpipe (LLVM 0x301)

        Device ID
        Gallium 0.4 on llvmpipe (LLVM 0x301)

        Driver Version
        2.1 Mesa 9.0

        GPU Accelerated Windows
        0/1 Basic Blocked for your graphics driver version.

        Vendor ID
        VMware, Inc.

        WebGL Renderer
        Blocked for your graphics driver version.

        AzureCanvasBackend
        cairo

        AzureContentBackend
        none

        AzureFallbackCanvasBackend
        none
(In reply to Virgil Dicu [:virgil] [QA] from comment #3)
> (In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #1)
> > Can you provide more details about what distribution, desktop environment,
> > and theme you are using?
> 
> Forgot to mention Ubuntu 12.04 LTS 64-bit whit a new clean profile, no
> themes or add-ons installed.

When I say "theme" I meant Ubuntu theme, not Firefox theme. The default Ubuntu theme is black whereas your screenshot shows a gray.
(Reporter)

Comment 8

5 years ago
I can reproduce the issue with the default Ubuntu theme as well on the machine with the ATI card specified in comment 3. So there must be something else involved here. 
Couldn't reproduce on a machine with an Nvidia card.

Will try to find another ATI machine and figure out the issues with the regression range.
(In reply to Virgil Dicu [:virgil] [QA] from comment #8)
> I can reproduce the issue with the default Ubuntu theme as well on the
> machine with the ATI card specified in comment 3. So there must be something
> else involved here. 
> Couldn't reproduce on a machine with an Nvidia card.
> 
> Will try to find another ATI machine and figure out the issues with the
> regression range.

On Ubuntu there are three different drivers: proprietary, open source, and fallback. Can you please check to see which of these drivers this bug reproduces?
FWIW, this does not reproduce for me on Ubuntu 12.04 with an AMD Radeon HD 7950 using the proprietary driver version "4.2.12002 Compatibility Profile Context 9.012". This seems to be a bit more up to date than what you are using. Can you trying using the latest available from AMD's website?
(Reporter)

Comment 11

5 years ago
Works fine after uninstalling the driver. Graphics section from about:support in Latest Nightly looks like this:

  Adapter Description: X.Org -- Gallium 0.4 on AMD CEDAR
  Device ID: Gallium 0.4 on AMD CEDAR
  Driver Version: 2.1 Mesa 8.0.4
  GPU Accelerated Windows: 0/1 Basic 
  Vendor ID: X.Org
  WebGL Renderer: X.Org -- Gallium 0.4 on AMD CEDAR

After installing the latest driver, downloaded from support.amd.com, text on notification panel is displayed correctly.

  Adapter Description: ATI Technologies Inc. -- ATI Radeon HD 5450
  Device ID: ATI Radeon HD 5450
  Driver Version: 4.2.12002 Compatibility Profile Context 9.012
  GPU Accelerated Windows: 0/1 Basic 
  Vendor ID: ATI Technologies Inc.
  WebGL Renderer: ATI Technologies Inc. -- ATI Radeon HD 5450       

I'll move this to invalid, as it works with a recent version of the video card.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.