All users were logged out of Bugzilla on October 13th, 2018

testAddons_changeTheme/restartTests fails with "AddonsManager_getAddonChildElement: Add-on has been specified. - got 'undefined' "

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: mario.garbi, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
http://mozmill-crowd.blargon7.com/#/functional/report/a83c700664548dba07298b74bf3805db

 When updating to latest Nightly (in our case 14.02.2013) from a previous version the test fails since we don't have the Default Theme element any more (completely disappears from AddonManager - Appearance instead of being disabled, greyed out).
(Reporter)

Updated

6 years ago
No longer blocks: 786306
I've raise a bug against Firefox for this regression
Depends on: 841384

Comment 2

6 years ago
Changing the Depends on field due to the fact that bug 841348 was marked Duplicate of bug 841094
Depends on: 841094
No longer depends on: 841384
Duplicate of this bug: 841839
How often is that test failing? Is there a need to skip it?

Comment 5

6 years ago
No need to skip it as this is happening only for us. It happenes because we upgraded Nightly instead of performing a clean install every day as the mozmill tests are doing.
So it will affect user reports send to the mozmill-crowd dashboard. I think that's fine and we can wait for the fix.
Hardware: x86 → All
Whiteboard: [needs bug 841094]
Fix is up, it's not reproducing anymore.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Whiteboard: [needs bug 841094]
You need to log in before you can comment on or make changes to this bug.