UnixSocket does not properly clean up delayed tasks on shutdown

RESOLVED DUPLICATE of bug 855453

Status

()

Core
DOM: Device Interfaces
RESOLVED DUPLICATE of bug 855453
5 years ago
5 years ago

People

(Reporter: qdot, Assigned: qdot)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

When running B2G Desktop, after fixing the initial crash in bug 840294, we get a new crash on shutdown due to the fact that the socket connect task isn't cancelled correctly, and it tries to create sockets while the rest of gecko is going down and removing pointers out from under it.

Part of the issue here is that we seem to have two ways to stop tasks, StopTask and CancelTask. These made sense before we had task delays (implemented as part of MultiRIL I think?), but now don't work.

Updated

5 years ago
No longer depends on: 846615

Updated

5 years ago
Depends on: 846615
Confirming that this is fixed via 846615 (rebased for m-c) plus another patch. Waiting 'til that lands, then will patch from there.
Duplicated and fixed in bug 855453
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 855453
You need to log in before you can comment on or make changes to this bug.