unable to delete saved search

VERIFIED FIXED in Thunderbird 22.0

Status

Thunderbird
Folder and Message Lists
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: helkav, Assigned: aryx)

Tracking

({regression})

21 Branch
Thunderbird 22.0
regression

Thunderbird Tracking Flags

(thunderbird20 fixed, thunderbird21 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0
Build ID: 20130201065344

Steps to reproduce:

created a saved search. was saved as virtual folder. later attempted to delete it. 


Actual results:

delete request is ignored, i.e. nothing happens


Expected results:

saved search should be deleted. messages found in search should be unaffected

Comment 1

4 years ago
Anything in Tools->Error console AFTER the failed attempt to delete the folder?

But I can confirm this problem. I wonder if this worked in the past.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

4 years ago
(In reply to :aceman from comment #1)
> Anything in Tools->Error console AFTER the failed attempt to delete the
> folder?
> 
> But I can confirm this problem. I wonder if this worked in the past.

nothing in error console

Comment 3

4 years ago
Ok, I see the problem, there is a typo from a recent change.

Tue Feb 19 2013 21:27:17
Error: ReferenceError: Servics is not defined
Source file: chrome://messenger/content/folderPane.js
Line: 2146

if (Servics.prompts
           .confirmEx(window, title, confirmation,

I assume Aryx will clean it up :)
Assignee: nobody → archaeopteryx
Status: NEW → ASSIGNED
OS: Windows 7 → All
Hardware: x86_64 → All
Created attachment 715678 [details] [diff] [review]
patch fixing typo, v1
Attachment #715678 - Flags: review?(kent)
Created attachment 715705 [details] [diff] [review]
patch fixing two typo, v2

There was a second typo in that line (or the cursor had been shifted one byte to the left), also fixing that.
Attachment #715678 - Attachment is obsolete: true
Attachment #715678 - Flags: review?(kent)
Attachment #715705 - Flags: review?(kent)

Updated

4 years ago
Attachment #715705 - Flags: review?(mkmelin+mozilla)

Comment 6

4 years ago
Comment on attachment 715705 [details] [diff] [review]
patch fixing two typo, v2

Review of attachment 715705 [details] [diff] [review]:
-----------------------------------------------------------------

nice catch, r=mkmelin!
Attachment #715705 - Flags: review?(mkmelin+mozilla) → review+

Updated

4 years ago
Blocks: 795152
Keywords: regression

Updated

4 years ago
Attachment #715705 - Flags: review?(kent)

Updated

4 years ago
Keywords: checkin-needed

Comment 7

4 years ago
(In reply to Archaeopteryx [:aryx] from comment #5)
> Created attachment 715705 [details] [diff] [review]
> patch fixing two typo, v2
> 
A typo in the description of a patch fixing a typo :) Nice one, Aryx ! :)

[missing 's']
https://hg.mozilla.org/comm-central/rev/f10a1c2973fd
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 22.0
(Reporter)

Comment 9

4 years ago
retested on daily 22-02-2013. fixed. nice one! thanks Aryx

Updated

4 years ago
Status: RESOLVED → VERIFIED

Comment 10

4 years ago
Comment on attachment 715705 [details] [diff] [review]
patch fixing two typo, v2

The original breaking patch went into TB20 so we may want to fix it there too.

[Approval Request Comment]
Regression caused by (bug #): bug 842008
User impact if declined: inability to delete virtual folder
Testing completed (on c-c, etc.): TB22
Risk to taking this patch (and alternatives if risky): none
Attachment #715705 - Flags: approval-comm-beta?
Attachment #715705 - Flags: approval-comm-aurora?
Comment on attachment 715705 [details] [diff] [review]
patch fixing two typo, v2

a=me
Attachment #715705 - Flags: approval-comm-beta?
Attachment #715705 - Flags: approval-comm-beta+
Attachment #715705 - Flags: approval-comm-aurora?
Attachment #715705 - Flags: approval-comm-aurora+
https://hg.mozilla.org/releases/comm-aurora/rev/42e9558e7cc3
status-thunderbird21: --- → fixed
https://hg.mozilla.org/releases/comm-beta/rev/fa8307cf2bda
status-thunderbird20: --- → fixed
You need to log in before you can comment on or make changes to this bug.