Closed Bug 842075 Opened 9 years ago Closed 9 years ago

addIceCandidate should not throw an Error on bogus values

Categories

(Core :: WebRTC: Signaling, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: ekr, Assigned: jib)

References

Details

(Whiteboard: [WebRTC], [blocking-webrtc-])

addIceCandidate will throw an error if (for instance) you create
a mozRTCCandidate with sdpMLineIndex === null. Instead, it
should fire the error callback.
Whiteboard: [WebRTC], [blocking-webrtc+]
Assignee: nobody → ekr
This seems like something that would make more sense for jib or abr. reassigning to jib.

also, it's pretty low pri.
Assignee: ekr → jib
Now that we know what's going on and the crashtests are no longer blocked, I'm making this blocking-.
Whiteboard: [WebRTC], [blocking-webrtc+] → [WebRTC], [blocking-webrtc-]
Duplicate of this bug: 842026
http://dev.w3.org/2011/webrtc/editor/webrtc.html#idl-def-RTCIceCandidate says of addIceCandidate:

  "An exception with an RTCError object of type INVALID_CANDIDATE_TYPE is thrown
   if candidate parameter is malformed."

Looks like throwing is the correct behavior, so I'm closing this as invalid.

(Our exceptions don't include RTCError objects, but that is a different matter).
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.