If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Windows builds using make fail

RESOLVED FIXED in mozilla22

Status

()

Core
Build Config
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: Robert Longson, Assigned: gps)

Tracking

({regression})

Trunk
mozilla22
x86_64
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Builds on Windows using make fail. Only pymake builds succeed.

c:/moz2/mozilla/obj-i686-pc-mingw32/_virtualenv/Scripts/python.exe /c/moz2/mozilla/addon-sdk/copy_source.py /c/moz2/mozilla /c/moz2/mozilla/addon-sdk/source/lib
 ../dist/bin/modules/commonjs >copy_source.mk
make -f copy_source.mk libs
make[1]: Entering directory `/c/moz2/mozilla/obj-i686-pc-mingw32/addon-sdk'
c:/moz2/mozilla/config/baseconfig.mk:20: *** Windows-style srcdir being used with GNU make. Did you mean to run c:/moz2/mozilla/build/pymake/make.py instead? [see-also:     https://developer.mozilla.org/en/Gmake_vs._Pymake].  Stop.
make[1]: Leaving directory `/c/moz2/mozilla/obj-i686-pc-mingw32/addon-sdk'
make: *** [libs] Error 2
(Reporter)

Updated

5 years ago
Blocks: 837915
(Reporter)

Updated

5 years ago
Keywords: regression
We should just fix bug 828317 and call this WONTFIX.
Point of reference, SeaMonkey hasn't switched to pymake in our builders yet officially.

So if there is an easy fix here, I'd love to see it. (Yes I know 828317 is around the corner)
I'd rather just rip the band-aid off, honestly, so we can stop having to fix silly things like this.
(Assignee)

Comment 4

5 years ago
Created attachment 716739 [details] [diff] [review]
Use UNIX style paths with GNU make on Windows, v1

This is oh so hacky. But, it only needs to be a stop-gap until we deprecate GNU make on Windows.

As it turns out, msys and/or Python is normalizing path-like command line arguments and environment variables to Windows style. Sigh.
Assignee: nobody → gps
Status: NEW → ASSIGNED
Attachment #716739 - Flags: review?(ted)
Comment on attachment 716739 [details] [diff] [review]
Use UNIX style paths with GNU make on Windows, v1

Review of attachment 716739 [details] [diff] [review]:
-----------------------------------------------------------------

Lame.
Attachment #716739 - Flags: review?(ted) → review+
(Assignee)

Comment 6

5 years ago
Do we still need this for SeaMonkey? Or, can we finally kill GNU make on Windows and make this WONTFIX?
Flags: needinfo?(bugspam.Callek)
I would appreciate an aurora-landing of this, but we don't need it on trunk, and we *can* survive without this on aurora now.
Flags: needinfo?(bugspam.Callek)
(Assignee)

Comment 8

5 years ago
Well, we can't kill pymake yet because of l10n. It's always l10n. So, landing this as a stop-gap.

https://hg.mozilla.org/integration/mozilla-inbound/rev/0887088eee1a
Target Milestone: --- → mozilla22
https://hg.mozilla.org/mozilla-central/rev/0887088eee1a
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Assignee)

Updated

4 years ago
Blocks: 926007
You need to log in before you can comment on or make changes to this bug.