Closed Bug 842911 Opened 9 years ago Closed 9 years ago

mini-app mode button on Samsung tablet can block content

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox18 unaffected, firefox19 wontfix, firefox20 verified, firefox21 fixed, firefox22 verified, fennec20+)

VERIFIED FIXED
Firefox 22
Tracking Status
firefox18 --- unaffected
firefox19 --- wontfix
firefox20 --- verified
firefox21 --- fixed
firefox22 --- verified
fennec 20+ ---

People

(Reporter: kbrosnan, Assigned: mfinkle)

References

Details

Attachments

(3 files)

Attached image Screenshot of the issue
The mini app mode button appears on top of content and the keyboard on a Samsung tablet.
Isn't this "mini app mode button" part of the OS? We do not have any code to show a button ourselves. We only enable it. Why is the OS being stupid? Does the button show for other "multi-window" apps?
Flags: needinfo?(kbrosnan)
Flags: needinfo?(kbrosnan)
No idea. I filed this based off forum feedback.
Flags: needinfo?(kbrosnan)
If we enable it,  can't we disable it?  Or did I read wrong?  By 'us' is that the user or the developer?
(In reply to Feer56 (Andrew T.) from comment #4)
> If we enable it,  can't we disable it?  Or did I read wrong?  By 'us' is
> that the user or the developer?

by "we enable it" mark means that we support the mini app mode that samsung introduced.
Let's remove this capability for now (since it's not a good UI) and fix this when there is time to fix it (this shouldn't take priority over other higher priority items).
Wes - Let's get a backout patch and try to push up to Fx20 (beta)
Assignee: nobody → wjohnston
tracking-fennec: ? → 20+
Flags: needinfo?(wjohnston)
Attached patch patchSplinter Review
Straight backout of bug 810415
Assignee: wjohnston → mark.finkle
Attachment #726415 - Flags: review?(blassey.bugs)
Comment on attachment 726415 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 810415
User impact if declined: floating button on many samsung devices
Testing completed (on m-c, etc.): none
Risk to taking this patch (and alternatives if risky): low, but i have no device to test
String or UUID changes made by this patch: none
Attachment #726415 - Flags: approval-mozilla-aurora?
Attachment #726415 - Flags: approval-mozilla-beta?
Attachment #726415 - Flags: review?(blassey.bugs)
Attachment #726415 - Flags: review+
Attachment #726415 - Flags: approval-mozilla-aurora?
Attachment #726415 - Flags: approval-mozilla-aurora+
Attachment #726415 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Landed on inbound
https://hg.mozilla.org/integration/mozilla-inbound/rev/28db68d1a57a

But the trees closed before I could get aurora and beta landed
Flags: needinfo?(wjohnston)
I really think we should leave this in. I haven't heard anything from users of these devices leading me to think this is just expected behaviour on these devices (QA hasnt answered our questions with regard to this). Given usage patterns on mobile are very transient for browsers this button seems like a fine expected tradeoff to me. Users that don't want multiapp mode can turn it off (can they?)
(In reply to Wesley Johnston (:wesj) from comment #11)
> I really think we should leave this in. I haven't heard anything from users
> of these devices leading me to think this is just expected behaviour on
> these devices (QA hasnt answered our questions with regard to this). Given
> usage patterns on mobile are very transient for browsers this button seems
> like a fine expected tradeoff to me. Users that don't want multiapp mode can
> turn it off (can they?)

I think we should flip this statement around: Until we have more feedback from users and can test this ourselves on more devices, we should back it out. I don't like _not_ knowing what's happening.
Backed out the inbound landing for breaking every Android 2.2 test, timeouts for non-talos, failed to initialize for talos, in https://hg.mozilla.org/integration/mozilla-inbound/rev/4673849a821e
> I really think we should leave this in. 

Same here, I use it fine without issue on my Galaxy Note II (Android 4.1)

> QA hasnt answered our questions with regard to this). 

Which?

> Users that don't want multiapp mode can turn it off (can they?)

Yes, you can make any capable application use it or not. Opera/Chrome both support it.
https://hg.mozilla.org/mozilla-central/rev/b036536b0252
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 22
User reported a constantly icon on a Galaxy Note 10.1
Status: RESOLVED → VERIFIED
OS: Linux → Android
Hardware: x86_64 → ARM
Users noticing that it worked fine for them on Beta and now removed and complaining in bug 854040.
(In reply to Aaron Train [:aaronmt] from comment #16)
> Which?
https://bugzilla.mozilla.org/show_bug.cgi?id=842911#c2

Namely, I want to know if this is expected behavior. Can you go into settings and turn it on/off (i.e. its the users decision to have the button there and there's a relatively easy workaround if they don't want it). It sounds like from your comment that they can? If so, it sounds like the reporter just accidentally turned it on and doesn't know how to turn it off (maybe on is default?)?

Its pretty hard to find much info on this, and the info I have found suggests that we have basically zero control over it beyond what we've done (enabling it). But I think not having it on basically makes us looked gimped compared to our competitors on a set of phones that are the largest selling and growing phones on the market.
So here is how it works on my Samsung Galaxy Note II (Android 4.1.2), provided I don't see this floating multi-window icon at all.

* In any application including the home-screen one may tap and hold on the device back to reveal this little blue tab panel with pre-set compatible applications (scrollable) and an edit button:  http://people.mozilla.com/~atrain/mobile/screenshots/mw/1.png, hitting the edit button lets you add additional applications http://people.mozilla.com/~atrain/mobile/screenshots/mw/2.png  

* Dragging a full-screen application http://people.mozilla.com/~atrain/mobile/screenshots/mw/3.png such in the case, Twitter over Chrome will make Twitter present and full-screen

* http://people.mozilla.com/~atrain/mobile/screenshots/mw/4.png Maps supports multi-window, so I can drag video into the area and create a multi-window http://people.mozilla.com/~atrain/mobile/screenshots/mw/5.png

This is all the capability I see on my Samsung Galaxy Note II, there are no other options or settings other then to disable Multi window completely in Android -> Display -> Multi-window checkbox.

This worked fine in Firefox when it was in there.

One complaint of it missing so far: http://goo.gl/lP6id
Can anyone reproduce the original issue? On a Galaxy Note 10.1 ?
We don't have one.
Duplicate of this bug: 854040
(In reply to Mark Finkle (:mfinkle) (use needinfo?) from comment #23)
> Can anyone reproduce the original issue? On a Galaxy Note 10.1 ?

Problem *still* exists on Galaxy Note 10.1, i.e. annoying multi-window button covers keys of soft-keyboard, making them inaccessible/unusable.
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.