pdf.js: poor keyboard control

RESOLVED DUPLICATE of bug 843653

Status

()

Firefox
PDF Viewer
RESOLVED DUPLICATE of bug 843653
5 years ago
5 years ago

People

(Reporter: harald.dunkel, Unassigned)

Tracking

19 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-ux])

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

open any multi-page pdf in pdf.js, e.g. http://www.mozilla.org/en-US/privacy-policy.pdf.
Select fit-to-page view in the top level menu.


Actual results:

I had to click into the document to get keyboard control (highly annoying if you are used to focus-follows-mouse and keyboard control). When I did, zoom mode changed back to automatic.

In Fit Page mode the PgUp and PgDn scroll just 99% of the page, i.e. if you run through the document using PgDn, you get an annoying black line between the pages slowly crawling from top to bottom. 


Expected results:

There should be no need to click on the pdf to enable keyboard control.

The zoom mode should not change without explicit user selection in the top level menu.

PgUp and PgDn should jump from one page to the next or previous page, as the [next page] and [previous page] buttons on the top do.

Updated

5 years ago
Component: Untriaged → PDF Viewer
OS: Linux → All
Hardware: x86_64 → All
Closing as duplicate of bug 843653.

(Second part of the bug changes the way HTML standard select tag works and might confuse users)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Whiteboard: [pdfjs-c-ux]
Duplicate of bug: 843653
You need to log in before you can comment on or make changes to this bug.