Closed Bug 842986 Opened 8 years ago Closed 8 years ago

Implement MozFrameLoaderOwner on HTMLFrameElement

Categories

(Core :: DOM: Core & HTML, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla22
Tracking Status
firefox21 + fixed
firefox22 + fixed

People

(Reporter: bzbarsky, Assigned: baku)

References

Details

Attachments

(1 file, 1 obsolete file)

See bug 838343 comment 4.

We're going to need to backport this to Aurora...
Attached patch patch (obsolete) — Splinter Review
Attachment #717156 - Flags: review?(bzbarsky)
Comment on attachment 717156 [details] [diff] [review]
patch

Why not put this function on nsGenericHTMLFrameElement so iframe can just share it?

r=me with that changed.
Attachment #717156 - Flags: review?(bzbarsky) → review+
Duplicate of this bug: 844462
Attached patch patchSplinter Review
A quick review?
Attachment #717156 - Attachment is obsolete: true
Attachment #717532 - Flags: review?(bzbarsky)
Comment on attachment 717532 [details] [diff] [review]
patch

r=me
Attachment #717532 - Flags: review?(bzbarsky) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/f5481770263d
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla22
Blocks: 847370
Attachment #717532 - Flags: approval-mozilla-aurora?
Attachment #717532 - Flags: approval-mozilla-aurora?
Comment on attachment 717532 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 838343 
User impact if declined:mozFrameLoaderOwner interface will miss from HTMLFrameElement
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): no one. try server is green and all the existing tests are passed.
String or UUID changes made by this patch:
Attachment #717532 - Flags: approval-mozilla-aurora?
Attachment #717532 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Crash Signature: blah blah
Crash Signature: blah blah
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.