etsy.com doesn't recognize B2G UA as mobile

RESOLVED FIXED

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: lmandel, Assigned: jsocol)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [uaoverride] [country-all] [sitewait], URL)

etsy.com serves a desktop site to B2G. Bug 823364 added an UA override for this domain. The override should be removed once the domain serves mobile content to B2G. This bug tracks the evangelism for the site to recognize the B2G UA and the removal of the override at that time.
Blocks: 843169
Whiteboard: [uaoverride]
I believe James as good contacts at Etsy and they should be able to resolve this one quickly!

Here's a pointer to our UA reference: https://developer.mozilla.org/en-US/docs/Gecko_user_agent_string_reference
(Assignee)

Comment 2

6 years ago
Yessir, Anthony! Happy to help.
Assignee: nobody → james

Comment 3

6 years ago
James reached us at Etsy and my team is looking into this along with some other mobile browser compatibility issues. You can reach me directly for updates at mike@etsy.com.

Comment 4

5 years ago
Hi Mike,

(In reply to Mike Brittain from comment #3)
> James reached us at Etsy and my team is looking into this along with some
> other mobile browser compatibility issues. You can reach me directly for
> updates at mike@etsy.com.

Do you have an update on the status of this bug?

Using the stock browser UA string on a Samsung, the etsy Web site is working as with the UA override in a ZTE firefox OS.

→ curl -s -A "Mozilla/5.0 (Linux; U; Android 2.3.5; en-us; GT-I9100 Build/GINGERBREAD) AppleWebKit/533.1 (KHTML, like Gecko) Version/4.0 Mobile Safari/533.1" http://www.etsy.com/ | grep -i Etsy.EventLoggerEvents.concat | sed -e 's/.*Etsy.EventLoggerEvents.concat(\[\(.*\)\]);Etsy.EventLogger.*/\1/' | python -m json.tool | grep '"is'


        "isEtsyApp": "0", 
        "isMobileDevice": "1", 
        "isMobileSupported": "1", 
        "isTabletSupported": "0", 
        "isTouch": "1", 


On the other hand, with the UA override removed, Etsy still serves the desktop version to Firefox OS. We would like to remove the override.


→ curl -s -A "Mozilla/5.0 (Mobile; rv:18.0) Gecko/18.0 Firefox/18.0" http://www.etsy.com/ | grep -i Etsy.EventLoggerEvents.concat | sed -e 's/.*Etsy.EventLoggerEvents.concat(\[\(.*\)\]);Etsy.EventLogger.*/\1/' | python -m json.tool | grep '"is'


        "isEtsyApp": "0", 
        "isMobileDevice": "1", 
        "isMobileSupported": "0", 
        "isTabletSupported": "0", 
        "isTouch": "0", 


You can reach me directly if you want Mike.
Flags: needinfo?(mike)

Updated

5 years ago
Whiteboard: [uaoverride] → [uaoverride] [country-all]

Comment 5

5 years ago
Thanks, Karl. I've followed up to your email. The summary is that we've lightly tested the purchase paths on Etsy and we're in OK shape to whitelist Firefox OS. Firefox on Android is already getting these templates due to the "Android" token.

We're going to update the UA sniffer shortly and I'll provide an update here.
Flags: needinfo?(mike)

Comment 6

5 years ago
Mike.

That's very good news. And thanks for the email explaining the issue. That's good news.

Updated

5 years ago
Whiteboard: [uaoverride] [country-all] → [uaoverride] [country-all] [sitewait]

Comment 7

5 years ago
Quick update! Etsy is now whitelisting the Firefox OS user-agent for our mobile templates. Be aware that we still have a number of areas in the site that don't render well for Firefox. I've confirmed, however, that our core browsing and purchasing funnels are *usable*.
Awesome! Thanks Mike!

Karl - Let's confirm and squash this override.

Comment 9

5 years ago
ok tested on ZTE device without UA override. Check a few things here and there. And it's working perfectly. 

Big big thanks to Mike and Etsy team.

I will create a pull request on the Gaia override by the end of this week.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.