Closed Bug 823364 Opened 7 years ago Closed 7 years ago

Add UA overrides for top Colombia, Poland, Spain, and Venezuela sites

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g18+ fixed)

RESOLVED FIXED
Tracking Status
b2g18 + fixed

People

(Reporter: lmandel, Unassigned)

References

Details

Attachments

(2 files, 1 obsolete file)

Note: This bug should remain confidential until Columbia has been publicly announced as a target market for B2G.

Attached is a candidate list of 14 of the Alexa top 100 Columbia sites for the B2G UA whitelist. This list of 14 sites was determined via screenshot comparison of the sites with the Firefox for Android, Firefox OS, and Android Stock UAs. Sites that are already included in bug 819210 are omitted here.

Our goal is to create a recommended list of Columbian sites for the UA whitelist.

There are 3 actions:

1. Smoke test each of these sites, preferably on B2G, with a spoofed UA to ensure that with the UA override the site appearance is improved and the site is mostly functional. Non primary function, like a vertically scrollable list of posters/images or function buried deep within the site, should not block a smoke test from passing.

2. Add the UA overrides to Gaia.

3. Open an evangelism bug for each site that is added to the UA override list in order to track the work required to remove a site from the list.

Legend for the attachment:
(Android UA) = This site requires the Android stock UA to get mobile content
(better content with Android UA) = This site receives mobile content with the Fennec UA but better mobile content with the Android stock UA
(nsfw) = not safe for work (this is an adult site)
I have added these to the user-agent override investigation spreadsheet for tracking.
Depends on: 822551
Triage: BB-, tracking-b2g+, please renom if there is major user impact
blocking-basecamp: ? → -
tracking-b2g18: --- → +
(In reply to Joe Cheng from comment #2)
> Triage: BB-, tracking-b2g+, please renom if there is major user impact

This is a requirement by product. Top sites won't work. Back into triage it goes.
blocking-basecamp: - → ?
tracking-b2g18: + → ---
I have added these to the user-agent override investigation spreadsheet for tracking.
blocking-basecamp: ? → -
(In reply to David Scravaglieri [:scravag] from comment #4)
> The target market is Brasil, we don't block on this.

No. Chris Lee confirmed that the target market isn't just Brazil. There's other involved here. That's the point of why we filed bugs for these UA overrides - they represent each market to our understanding. Into triage it goes again.
blocking-basecamp: - → ?
Jason, any bugs that are post C3, but still valid work for v1.0, will no longer use blocking-basecamp flag. instead, it is replaced by tracking-b2g18 flag.   We'll want these override bugs for non-brazil to get tracking-b2g18+'d.   

so comment 2 is correct.
blocking-basecamp: ? → -
tracking-b2g18: --- → ?
(In reply to Tony Chung [:tchung] from comment #6)
> Jason, any bugs that are post C3, but still valid work for v1.0, will no
> longer use blocking-basecamp flag. instead, it is replaced by tracking-b2g18
> flag.   We'll want these override bugs for non-brazil to get
> tracking-b2g18+'d.   
> 
> so comment 2 is correct.

Wrong. Last time I checked, triage is still going on. So that argument doesn't make sense to me.
blocking-basecamp: - → ?
Being pedantic: changing "Columbia" to "Colombia"
Summary: Add UA overrides for top Columbia sites → Add UA overrides for top Colombia sites
blocking-basecamp: ? → ---
Attached patch UA overrides patch (obsolete) — Splinter Review
UA overrides for Colombia. While this doesn't block basecamp it would be valuable to add uplift this patch to b2g18 before we release in this locale.
Attachment #698990 - Flags: review?(21)
I'm going to merge 4 override bugs into this one and provide one large patch - coming shortly.
Summary: Add UA overrides for top Colombia sites → Add UA overrides for top Colombia, Poland, Spain, and Venezuela sites
Duplicate of this bug: 823365
Duplicate of this bug: 823368
Duplicate of this bug: 824109
While not a blocker, it would be good to land this while we still can.
Attachment #698990 - Attachment is obsolete: true
Attachment #698990 - Flags: review?(21)
Attachment #699844 - Flags: review?(21)
Comment on attachment 699844 [details] [diff] [review]
UA overrides for CO, ES, PL, and VE

I forgot to r+a=me.
Attachment #699844 - Flags: review?(21)
Attachment #699844 - Flags: review+
Attachment #699844 - Flags: approval-gaia-master+
Removing the confidential flag now that these locales have been publicly announced as launch markets.

https://blog.mozilla.org/press/2013/02/firefox-os-expansion/
Group: mozilla-corporation-confidential
You need to log in before you can comment on or make changes to this bug.