Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Transparent part of PDF is opaque in Firefox

RESOLVED FIXED

Status

()

Firefox
PDF Viewer
P3
normal
RESOLVED FIXED
5 years ago
10 months ago

People

(Reporter: vincentnoiseux, Unassigned)

Tracking

19 Branch
x86
All
Points:
---

Firefox Tracking Flags

(firefox20-, firefox21-)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-trans-group][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/2936)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:19.0) Gecko/20100101 Firefox/19.0
Build ID: 20130215130331

Steps to reproduce:

Visited http://forms.tenaquip.com/0002.pdf


Actual results:

Watermark shows opaque in Firefox.


Expected results:

Watermark should be transparent.

Updated

5 years ago
Component: Untriaged → PDF Viewer
confirming with a 5day old Firefox trunk on windows7
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Duplicate of this bug: 843752
Duplicate of this bug: 844182

Updated

4 years ago
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-trans-group]
Duplicate of this bug: 850311
tracking-firefox20: --- → ?
tracking-firefox21: --- → ?

Comment 5

4 years ago
Not user critical, not tracking for release. Please nominate for branch approval if/when a fix is found.
tracking-firefox20: ? → -
tracking-firefox21: ? → -
(Reporter)

Comment 6

4 years ago
This bug makes it impossible to read some PDF with transparency.

http://promo.sico.ca/en/download/pro_con_evo_post_trial.pdf is an example.

Updated

4 years ago
Whiteboard: [pdfjs-c-rendering][pdfjs-d-trans-group] → [pdfjs-c-rendering][pdfjs-d-trans-group][pdfjs-f-fixed-upstream]https://github.com/mozilla/pdf.js/pull/2936
Duplicate of this bug: 854205
WFM in current nightly(23).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 9

10 months ago
UserAgent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:49.0) Gecko/20100101 Firefox/49.0
BuildID: 20160916101415

This bug is back...

Example: http://www.a-pdf.com/watermark/examples/sample(rotatetext).pdf

while it should look like the preview: http://www.a-pdf.com/watermark/example.htm (2nd row, 3rd column).

Actual results:

PDF renders but watermark is topmost layer and doesn't support opacity.


Expected results:

The watermark should be bottommost layer and be almost transparent.

This bug makes it impossible to read some PDF with transparency.

Comment 10

10 months ago
Please open a new bug and post a screenshot.

Comment 11

10 months ago
(In reply to JPC from comment #9)
> UserAgent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:49.0) Gecko/20100101
> Firefox/49.0
> BuildID: 20160916101415
> 
> This bug is back...
> 
> Example: http://www.a-pdf.com/watermark/examples/sample(rotatetext).pdf
> 
> while it should look like the preview:
> http://www.a-pdf.com/watermark/example.htm (2nd row, 3rd column).

It's Bug 1304353.
You need to log in before you can comment on or make changes to this bug.