Closed Bug 843365 Opened 7 years ago Closed 7 years ago

Requesting gUM access, releasing it a few times on gum test page - video eventually fails to show anything

Categories

(Core :: WebRTC: Audio/Video, defect)

ARM
Android
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: jsmith, Unassigned)

References

Details

(Whiteboard: [getUserMedia][blocking-gum-][android-gum+])

Attachments

(4 files)

Device: Galaxy Nexus, Galaxy S3
OS: Android 4.1

Steps:

1. Go to http://mozilla.github.com/webrtc-landing/gum_test.html
2. Select video
3. Hit stop
4. Repeat step #2 and step #3 a few times

Expected:

When video is selected, we should render the camera stream in the video element.

Actual:

After 3 - 5 times, I'll eventually see no video render at all.
Whiteboard: [getUserMedia][blocking-gum-][android-gum+]
Duplicate of this bug: 843708
Attached file Debug log
Debug log from a debug build with:
 adb shell am start -a android.activity.MAIN -n org.mozilla.fennec/.App --es env0 NSPR_LOG_MODULES=MediaManager:5,GetUserMedia:5 

The log contains a few successful clicks on the "Audio & Video" link of the gum test page, and the first failure, I cut the log just when it failed for the first time.
Attached file Debug log 2
The beginning is the same as attachment 716716 [details] but I also included another few failures.
Attached file Debug log 3
adb shell am start -a android.activity.MAIN -n org.mozilla.fennec/.App --es env0 NSPR_LOG_MODULES=mediamanger:5,getusermedia:6,mediastreamgraph:5

Includes 2 failures.
gzipped as the log is much larger.
Attached file Debug log 4
getusermedia:7,mediamanager:5,mediastreamgraph:5 and video-only
Does this problem still reproduce?
(In reply to Gian-Carlo Pascutto (:gcp) from comment #6)
> Does this problem still reproduce?

I believe the last time I checked this recently (maybe a week ago?) I was still able to reproduce this very easily.

Are you able to reproduce this?
With the fix for bug 873812 on my tree I'm not able to reproduce this at all.
Okay, I'll dupe it to bug 873812 then since the root cause is being fixed there.
No longer blocks: android-webrtc
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 873812
I wouldn't say that. It's just that without that fix on the current tree WebRTC is significantly broken. It may or may not fix this issue. I'd love for you to verify/try as soon as that other bug lands.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Okay. I'll wait that patch to land to start testing this again.
QA wanted for a retest to see if the associated bug mentioned above fixed this issue.
Keywords: qawanted
QA Contact: jsmith
This is much better than it was previous to the landing of the patch in the aforementioned bug. Testing comment #0 on Nightly (06/02), on my HTC One (Android 4.1) and Galaxy S4 (Android 4.2), I am seeing a clean start and stop and permission request each time now. Resolving this as WORKSFORME.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Keywords: qawanted
Resolution: --- → WORKSFORME
No longer blocks: android-webrtc
You need to log in before you can comment on or make changes to this bug.