Closed Bug 843523 Opened 7 years ago Closed 7 years ago

[Progress Events] getOwnPropertyDescriptor() on ProgressEvent.prototype fails

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 560072

People

(Reporter: jungkee.song, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.70 Safari/537.17

Steps to reproduce:

ProgressEvent CR (http://www.w3.org/TR/progress-events/) test
- Test wiki: http://www.w3.org/wiki/Webapps/Interop/ProgressEvents
- Test suite: http://w3c-test.org/webapps/ProgressEvents/tests/
- Test case: http://w3c-test.org/webapps/ProgressEvents/tests/submissions/Ms2ger/interface.html
(3)(4)(5) The ProgressEvent interface 1, 2, 3


Actual results:

Test case failed:
var desc = Object.getOwnPropertyDescriptor(ProgressEvent.prototype, a[1]); 
raises
NS_ERROR_XPC_BAD_OP_ON_WN_PROTO: Illegal operation on WrappedNative prototype object


Expected results:

var desc = Object.getOwnPropertyDescriptor(ProgressEvent.prototype, a[1]); 
returns valid descriptor and subsequent assertions are passed.
Will be fixed by bug 776864.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 560072
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.